Bug 148993 - Random segfaults, and error 139s when forking processes
Random segfaults, and error 139s when forking processes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 14:58 EST by Robin Green
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 17:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-02-17 14:58:17 EST
Description of problem:
On Xen, with two domains running (dom0 is FC3 and dom1 is Specifix Linux 0.20),
I keep getting (a) random segfaults occassionally, and (b) random error 139s
from python code that is forking-and-execing processes. Every time, if I repeat
the action that precipitated the segfault or error 139, it works the second time
around.

Version-Release number of selected component (if applicable):
xen-2-20050207

How reproducible:
Not reproducable
Comment 1 Rik van Riel 2005-03-07 17:07:27 EST
kernel 2.6.11-1.1176_FC4 has your bugfix in it.  Since you have tested it too,
I'm closing out this bug.

Note You need to log in before you can comment on or make changes to this bug.