Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1489935 - Error when deploying with no tunnelling
Summary: Error when deploying with no tunnelling
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ga
: 12.0 (Pike)
Assignee: Dan Sneddon
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1494219
TreeView+ depends on / blocked
 
Reported: 2017-09-08 17:45 UTC by Steve Reichard
Modified: 2018-02-05 19:12 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.3-0.20171023134947.8da5e1f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1494219 (view as bug list)
Environment:
Last Closed: 2017-12-13 22:08:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1718797 0 None None None 2017-09-21 22:09:29 UTC
OpenStack gerrit 499524 0 None None None 2017-09-20 22:37:14 UTC
OpenStack gerrit 505841 0 None None None 2017-09-21 22:16:50 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Steve Reichard 2017-09-08 17:45:03 UTC
Description of problem:

 I attempted my fist BM OSP12 bare metal deployment on my cluster that use VLAN tenant networking. This was using the 9-6.1 puddle.

As I did with OSP111, I used the network-isolation-no-tunelling.yaml, since it was there.   However this seems to reference other yamls which no linger exist. E.G. the first error I got was from network/internal_api.yaml.  This didn't exist but the interanl_api_v6.yaml does.

I assume this is related to using composable_networks and teh no tunnelling yaml just wasn' t cleaned up.  Also have not found documentation on composable networks.


Version-Release number of selected component (if applicable):
 This was using the 9-6.1 puddle.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Alex Schultz 2017-09-11 19:15:20 UTC
Please provide deployment commands, templates and logs.  The missing files are generated by the network data so if you aren't properly configuring the roles and networks it could result in these files erroring.  Similar to Bug 1488837

Comment 2 Steve Reichard 2017-09-13 16:37:26 UTC
I redeployed with the 09-08.3 puddle with similar results.

Deploy command:
#!/bin/bash -x

PROJECT=$(basename `dirname $0`)


date


source stackrc

openstack overcloud deploy \
--templates \
--environment-directory /home/stack/mytemplates/env \
--roles-file /home/stack/mytemplates/roles_data.yaml \
--stack ${PROJECT} \
--debug \
--log-file overcloudDeploy.log

date


Copied the mytemplates subdirectory and log file and a tee of the output of the deploy command to:

http://refarch.cloud.lab.eng.bos.redhat.com/pub/tmp/bz1489935/

If you want any other logs, please let me know which or if easier if you want sosreports, let me know which node types to gather.

Comment 3 Alex Schultz 2017-09-19 16:46:40 UTC
Steve, can you take a look at these templates?  At first glance it seems to be related to the network refactoring

Comment 4 Alex Schultz 2017-09-20 21:43:27 UTC
In reviewing, I think the file might be wrong and OS::TripleO::Network::Tenant should be set to OS::Heat::None and not ../network/noop.yaml.  We have a similar setup in the net-single-nic-with-vlans-no-external.yaml

https://github.com/openstack/tripleo-heat-templates/blob/67b14a599689178fbee31068231d636baeacb606/environments/net-single-nic-with-vlans-no-external.yaml#L13

Can you try switching that out and testing it? If that resolves it I can work on fixing this file upstream and doing the appropriate backports.

Comment 9 Gurenko Alex 2017-12-12 16:03:59 UTC
Verified on build 2017-12-06.2

Comment 12 errata-xmlrpc 2017-12-13 22:08:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.