Bug 149003 - cman-kernel rpm not properlly detecting conflicts
cman-kernel rpm not properlly detecting conflicts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 16:22 EST by Adam "mantis" Manthei
Modified: 2010-01-04 14:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 14:07:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam "mantis" Manthei 2005-02-17 16:22:42 EST
Description of problem:
The cman-kernel rpm does not detect when files conflict.  The cman-kernel rpm
needs to be able to install multiple versions on a system at the same time for
the case when the rpms are for different kernel versions.  This allows a user to
move from an older kernel to a newer kernel, and back again if neccesarry.  
For example, a user could have both kernels 2.6.9-1.906 and 2.6.9-5 installed,
and would consequently require two versions of cman-kernel to be installed as well.

The problem right now is that there is no checking for conflicting files, so if
two cman-kernel packages were built for the same kernel, both packages could be
installed causing one to overwrite the other without any warning given to the
user.  In this case, the rpm needs to be able to detect that there are
conflicting files and abort the install, requiring --upgrade to be used instead.

Version-Release number of selected component (if applicable):
cman-kernel-2.6.9-18.0.i686.rpm
cman-kernel-2.6.9-20.0.i686.rpm
(I think the other -kernel rpms have the same problem)

How reproducible:
always

Steps to Reproduce:
1. rpm -iv cman-kernel-2.6.9-18.0.i686.rpm
2. rpm -iv cman-kernel-2.6.9-20.0.i686.rpm

  
Actual results:
#
# I installed two version of cman
#
[root@trin-04 ~]# rpm -qa | grep cman-kernel
cman-kernel-2.6.9-18.0
cman-kernel-2.6.9-20.0

#
# A listing shows that both version isntall their files in the same place
#
[root@trin-04 ~]# rpm -ql cman-kernel-2.6.9-18.0
/lib/modules
/lib/modules/2.6.9-5.EL
/lib/modules/2.6.9-5.EL/kernel
/lib/modules/2.6.9-5.EL/kernel/cluster
/lib/modules/2.6.9-5.EL/kernel/cluster/cman.ko
/lib/modules/2.6.9-5.EL/kernel/cluster/cman.symvers
/lib/modules/2.6.9-5.ELsmp
/lib/modules/2.6.9-5.ELsmp/kernel
/lib/modules/2.6.9-5.ELsmp/kernel/cluster
/lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.ko
/lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.symvers

[root@trin-04 ~]# rpm -ql cman-kernel-2.6.9-20.0
/lib/modules
/lib/modules/2.6.9-5.EL
/lib/modules/2.6.9-5.EL/kernel
/lib/modules/2.6.9-5.EL/kernel/cluster
/lib/modules/2.6.9-5.EL/kernel/cluster/cman.ko
/lib/modules/2.6.9-5.EL/kernel/cluster/cman.symvers
/lib/modules/2.6.9-5.ELsmp
/lib/modules/2.6.9-5.ELsmp/kernel
/lib/modules/2.6.9-5.ELsmp/kernel/cluster
/lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.ko
/lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.symvers

#
# rpm verify fails for the version installed first since it's files were 
# overwritten by the later version
#
[root@trin-04 ~]# rpm -qV cman-kernel-2.6.9-18.0
S.5....T    /lib/modules/2.6.9-5.EL/kernel/cluster/cman.ko
.......T    /lib/modules/2.6.9-5.EL/kernel/cluster/cman.symvers
S.5....T    /lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.ko
.......T    /lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.symvers

#
# these files are OK
#
[root@trin-04 ~]# rpm -qV cman-kernel-2.6.9-20.0

#
# remove the old rpm
#
[root@trin-04 ~]# rpm -e cman-kernel-2.6.9-18.0

#
# It takes the files with it leaving the updated system in a BadState
#
[root@trin-04 ~]# rpm -qV cman-kernel-2.6.9-20.0
missing     /lib/modules/2.6.9-5.EL/kernel/cluster/cman.ko
missing     /lib/modules/2.6.9-5.EL/kernel/cluster/cman.symvers
missing     /lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.ko
missing     /lib/modules/2.6.9-5.ELsmp/kernel/cluster/cman.symvers


Expected results:


Additional info:
Comment 1 Chris Feist 2005-02-24 18:13:49 EST
This seems to be a problem with rpm, I've filed a bug on rpm bz#149425
which when fixed will hopefully resolve this problem.
Comment 2 Chris Feist 2005-03-14 14:24:15 EST
Turns out the kernel rpm provides 'kernel = 2.6.9', which matches the
'Requires: kernel=2.6.9-5.EL' as well as 'Requires:
kernel=2.6.9-8.EL'. I've modified cman-kernel (and dlm-kernel,
gnbd-kernel, GFS-kernel) to Require /lib/modules/xxxx instead. 
(Changes will be in the 2nd build on 3/14 & after.)

Note You need to log in before you can comment on or make changes to this bug.