Bug 149005 - gnumeric source rpm package fails prey to linking problems on x86_64
gnumeric source rpm package fails prey to linking problems on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 16:25 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 03:22:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-02-17 16:25:47 EST
Description of problem:

On x86_64 machine:
$ rpmbuild --rebuild gnumeric-1.4.2-2.src.rpm
.......
.... -lxml2 -lpthread -lz -lglib-2.0 /usr/lib/libpopt.so -lm
/usr/lib/libpopt.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status

According to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138742#c22
the problem lies between gnumeric source tarball and gnumeric.spec
which fails to do

libtoolize --force --copy && aclocal && autoconf

Indeed, replacing in a spec file just 'autoconf' with the line
above generates link command which look for libraries in the
right places and everything recompiles.

It is true that one gets these:

acinclude.m4:17: warning: underquoted definition of AM_PATH_PROG_WITH_TEST
  run info '(automake)Extending aclocal'
  or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal
acinclude.m4:67: warning: underquoted definition of AM_LC_MESSAGES
acinclude.m4:92: warning: underquoted definition of AM_WITH_NLS
acinclude.m4:270: warning: underquoted definition of AM_GNU_GETTEXT
/usr/share/aclocal/libole2.m4:18: warning: underquoted definition of
AM_PATH_LIBOLE2

but that too is not so difficult to correct.

It seems that the problem is really much wider but I run into it
in a specific case of gnumeric.

Version-Release number of selected component (if applicable):
The above is using gnumeric-1.4.2-2 but AFAIK all earlier versions
are affected the same way and sources from FC3 too.
Comment 1 Caolan McNamara 2005-02-18 04:08:02 EST
I'll respin with that.

Note You need to log in before you can comment on or make changes to this bug.