Bug 149010 - cannot preserve disk information on "new" install
cannot preserve disk information on "new" install
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 16:46 EST by Hisashi T Fujinaka
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-20 21:13:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hisashi T Fujinaka 2005-02-17 16:46:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.6 (KHTML, like Gecko) Safari/125.12

Description of problem:
I'm not even sure this is anaconda but there's no "INSTALLER" in the drop-down.

1) Using the new RHEL4 iso, I'm trying to upgrade my RHEL4 installation, preserving /hdb which mounts as /home. The installer thinks /dev/hdb1 is ntfs. Using Alt-F2 to give me another shell, I ran "fdisk /dev/hdb" and "P" shows '/dev/hdb1' to be 83, Linux.

I did this because I want a clean install. Yesterday I upgraded from RHEL AS 3 -> RHEL AS 4 and now I want to try a "clean" install preserving /home.

2) The text installer "highlighting" is reversed on selecting install vs. upgrade.

3) On the "full" install, there's no way to preserve any of the partitions.

Version-Release number of selected component (if applicable):
don't know

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 3 AS
2. Upgrade RHEL 3 AS -> RHEL 4 AS
3. Try to delete SOME partitions (in my case preserve /dev/hdb1 as /home).
    

Actual Results:  No possibility to preserve partitions, or the installer now thinks type 83 Linux partition is NTFS.

Expected Results:  A new install, but preserving /home.

Additional info:
Comment 1 Jay Turner 2005-02-18 07:04:21 EST
On the "full" install, what did Disk Druid show for the various partitions?  You
should have been able to select "autopartition" or "manually partition using
Disk Druid"  The second option should have allowed you to select /dev/hdb1 as
/home and not format it (in order to preserve it.)

Has Windows every been on that drive?  I'm trying to figure out why something
would have thought it was NTFS.
Comment 2 Hisashi T Fujinaka 2005-02-18 16:42:07 EST
I am uncertain which screen is actually disk druid any longer. On the screen I think is disk druid, I can 
select auto or manual partition and I can choose to NOT format /dev/hdb1, but I can't select it since                                             
something thinks it's NTFS.
                                                                                                              
Since this is a Dell OptiPlex, it may have had Windows on it at some time. The company I bought it from 
had RedHat 8 or 9 on it, however, and I've put FC1, RH9, RHEL AS 3, and now RHEL AS 4 on it (in that 
order).

I think this could be some oddness in the LV manager. Before I started  "clean" last night, I formatted /
dev/hda1 and was able to mount /dev/hdb1 as /home by hand. I couldn't mount /dev/hdb1 until I                                                
explicitly told it that the disk was ext3; mount thought it was ntfs.
Comment 3 Jeremy Katz 2005-02-20 15:41:34 EST
If you run parted on /dev/hdb, what does it show the filesystem type as?
Comment 4 Hisashi T Fujinaka 2005-02-20 16:20:15 EST
Unfortunately, I couldn't wait and I let the installer do its thing, destroying all the old data.

To clarify something in Comment #2, using "mount /dev/hdb /home" gave me errors 
telling me it was an ntfs system, but "mount -t ext3 /dev/hdb /home" worked fine.
Comment 5 Jeremy Katz 2005-02-20 21:13:36 EST
Without more information here, there's not much I can do.  There was
probably some stale metadata leading to parted being confused, but
without getting that information, it's basically impossible to fix.
Comment 6 Hisashi T Fujinaka 2005-02-20 22:04:15 EST
OK. I hoped this was reproducible, but I couldn't leave the system the way it was. Not 
every company has spare hardware sitting around.

This does not speak well of RedHat, either.

Note You need to log in before you can comment on or make changes to this bug.