Bug 14902 - FTP installation hangs if RedHat mirror is stored in /
FTP installation hangs if RedHat mirror is stored in /
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-31 14:40 EDT by Ucender
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-29 12:28:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ucender 2000-07-31 14:40:21 EDT
If the RedHat mirror is stored in the root of the anonymous ftp server
(which is quiet uncommon), the installation will hang. The reason is that
the installation script runs the following command on the FTP server: "CWD
". In this case, CWD takes no argument because the mirror is in the root,
but unfortunately, the scripts adds a space after CWD, so the command is
not understood by the FTP server (wu-ftpd-2.6.0-3). Then the scripts loops
indefinitely, and the installation won't happen.
Comment 1 Erik Troan 2000-08-08 15:20:05 EDT
This is a bug in python's ftp module, which we should fix eventually.
Comment 2 Erik Troan 2000-09-29 12:28:32 EDT
Fixed in RH 7

Note You need to log in before you can comment on or make changes to this bug.