Bug 149020 - Patch with check for -Wextra in elfutils doesn't really work
Summary: Patch with check for -Wextra in elfutils doesn't really work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: elfutils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elena Zannoni
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-17 22:50 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 03:51:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
elfutils-0.101-wextra.patch (6.62 KB, patch)
2005-02-17 22:50 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2005-02-17 22:50:08 UTC
Description of problem:
Patch with check for -Wextra in elfutils doesn't really work:

if gcc -D_GNU_SOURCE -DHAVE_CONFIG_H -I. -I/usr/src/redhat/BUILD/elfutils-
0.101/build-i386-redhat-linux/../libcpu -I.. -I/usr/src/redhat/BUILD/elfutils-
0.101/build-i386-redhat-linux/../libcpu   -Wall -Wshadow -Werror -Wextra 
-Wformat=2 -Wunused -O2 -g -march=i386 -mcpu=i686 -MT i386_dis.o -MD -MP -MF 
".deps/i386_dis.Tpo" -c -o i386_dis.o /usr/src/redhat/BUILD/elfutils-
0.101/build-i386-redhat-linux/../libcpu/i386_dis.c; \
then mv -f ".deps/i386_dis.Tpo" ".deps/i386_dis.Po"; else rm -f ".deps/i386
_dis.Tpo"; exit 1; fi
cc1: unrecognized option `-Wextra'
make[1]: *** [i386_dis.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/elfutils-0.101/build-i386-
redhat-linux/libcpu'
make: *** [install-recursive] Fehler 1

Version-Release number of selected component (if applicable):
elfutils-0.101-2

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. Use a compiler that doesn't have -Wextra (RHEL3's gcc for example)
2. Rebuild elfutils-0.101-2
3. Die with an error
  
Actual results:
Patch with check for -Wextra in elfutils doesn't really work.

Expected results:
Rebuilding also should work without the -Wextra parameter. The attached patch 
solves the problem for me.

BTW, gcc 3.2.x also has problems with the changes in src/strip.c of the 
elfutils-0.101-portability.patch - but I guess, this is irrelevant for 
Fedora Core.

Comment 1 Robert Scheck 2005-02-17 22:50:09 UTC
Created attachment 111183 [details]
elfutils-0.101-wextra.patch

Comment 2 Roland McGrath 2005-05-17 03:51:22 UTC
This is not really a supported issue since it doesn't come up if you are using
the stock compiler.  Anyway, the current rawhide elfutils srpm contains a
portability patch that does work with older compilers, you have to use rpmbuild
--with compat to build the srpm using that patch.


Note You need to log in before you can comment on or make changes to this bug.