Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1490361 - red border around windows after upgrade to 7.4
Summary: red border around windows after upgrade to 7.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: darktable
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1420227
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-11 12:17 UTC by jeskenis
Modified: 2017-11-16 15:49 UTC (History)
5 users (show)

Fixed In Version: darktable-2.0.7-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-16 15:49:22 UTC
Type: Bug


Attachments (Terms of Use)

Description jeskenis 2017-09-11 12:17:14 UTC
I've noticed that after upgrading Centos to v 7.4 I have annoying red borders around darktable window. Reinstalling didn't help.
When I compiled 2.0.7 from source it worked correctly.

Comment 1 Germano Massullo 2017-09-11 13:07:27 UTC
GTK developers updated the libraries and darktable needs to be rebuilt

Comment 2 Germano Massullo 2017-09-11 13:13:22 UTC
As soon a new exiv version will be released into repositories, I will make an upgrade to 2.2.5

Comment 3 jeskenis 2017-09-11 13:57:25 UTC
thx for the update Germano - hope you'll be able to pull it out. New version of Darkatble would be awesome (I've settled on building 2.0.7 as later versions need cmake 3.0 - and that was showstopper for me).

Comment 4 Germano Massullo 2017-09-11 14:15:23 UTC
(In reply to jeskenis from comment #3)
> thx for the update Germano - hope you'll be able to pull it out. New version
> of Darkatble would be awesome (I've settled on building 2.0.7 as later
> versions need cmake 3.0 - and that was showstopper for me).

Actually only exiv version prevents darktable 2.2.5 to be built on EPEL7 repository :-)

Comment 5 cparg 2017-11-08 08:38:14 UTC
I ran into the same problem. T
This is a problem in the /usr/share/darktable/darktable.css file.

See: https://www.mail-archive.com/darktable-user@lists.darktable.org/msg03021.html

It can be fixed be replacing this file by the one in the message mentioned above.

Comment 6 Germano Massullo 2017-11-08 09:19:37 UTC
(In reply to cparg from comment #5)
> I ran into the same problem. T
> This is a problem in the /usr/share/darktable/darktable.css file.
> 
> See:
> https://www.mail-archive.com/darktable-user@lists.darktable.org/msg03021.html
> 
> It can be fixed be replacing this file by the one in the message mentioned
> above.

NO you are simply shutting down a symptom, not the cause.
GTK has been updated by maintainers but darktable needs to be compiled again against new version of GTK.
So this triggers the red borders.
The darktable sources available in EPEL repository do not compile cause old exiv2 library https://bugzilla.redhat.com/show_bug.cgi?id=1420227 and I will not revert the sources to an older version because this will force to use in darktable spec file, the Epoch tag forever.

This is the best choice at the moment, because:
1) new exiv2 is going to be released in RHEL/CentOS;
2) darktable is still working even with those annoying borders.

So as workaround I suggest you to compile and install darktable from sources on your own

Comment 7 cparg 2017-11-08 12:39:43 UTC
Hello Germano,

thanks for clarifying. 

Having the newest Darktable release available is certainly desirable (but a different request than solving this bug)!
Wouldn't it be the straight forward fix for this particular problem just to re-build 2.0.7 against the current GTK3 version (3.22.10) from the base repo ?

So that darktable-2.0.7-2.el7 becomes darktable-2.0.7-3.el7 !?

It sounds to be a pure distro-/build-problem.

Note concerning your 2): Also certain buttons are to large, which has a slight impact on functionality. So it's a little more than a cosmetic annoyance.

Getting the exiv2 issue resolved seem to be quite an effort due to the many broken dependencies to it.

Thx

 Christian

Comment 8 Germano Massullo 2017-11-08 12:49:26 UTC
(In reply to cparg from comment #7)

> Wouldn't it be the straight forward fix for this particular problem just to
> re-build 2.0.7 against the current GTK3 version (3.22.10) from the base repo
> ?
> 
> So that darktable-2.0.7-2.el7 becomes darktable-2.0.7-3.el7 !?

Give me some hours and I will do some tries

Comment 9 Germano Massullo 2017-11-08 23:44:23 UTC
https://bodhi.fedoraproject.org/updates/darktable-2.0.7-3.el7
Please leave a karma feedback
Thank you

Comment 10 Fedora Update System 2017-11-09 02:07:42 UTC
darktable-2.0.7-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-04c5bfc8f6

Comment 11 cparg 2017-11-09 10:34:27 UTC
Hello Germano,

I can confirm that darktable-2.0.7-3.el7 from the epel-testing repo fixes this problem.

Many thanks for your quick resolution.

Looking forward to see Darktable v2.5.x once all the exiv2 dependencies are sorted out.

Regards,
  Christian

Comment 12 Fedora Update System 2017-11-16 15:49:22 UTC
darktable-2.0.7-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.