Bug 1490388 - Installer doesn't components like router and registry due to Networking issues with Node flapping between Ready and NotReady State.
Summary: Installer doesn't components like router and registry due to Networking issue...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Ben Bennett
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On: 1473858 1594310
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-11 12:55 UTC by Miheer Salunke
Modified: 2018-06-22 15:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-14 19:11:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 10 Ben Bennett 2017-09-13 18:56:35 UTC
I think this is fundamentally due to the problem identified at step 4 where the pod and service IP ranges overlap.

That is addressed by bug https://bugzilla.redhat.com/show_bug.cgi?id=1473858

Once that issue is addressed we can work out if there are other problems or if that is the root cause of everything.

Comment 11 Ben Bennett 2017-09-13 18:57:31 UTC
*** Bug 1491394 has been marked as a duplicate of this bug. ***

Comment 13 Ben Bennett 2017-09-14 19:11:49 UTC
The MTU was not set correctly for the interface (based on the underlying OpenStack networking configuration).

This was messing the etcd traffic up and making all sorts of things misbehave.


Note You need to log in before you can comment on or make changes to this bug.