Bug 1490667 - Wordpress Download page redirects to old things.
Summary: Wordpress Download page redirects to old things.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: website
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-12 00:55 UTC by Amye Scavarda
Modified: 2017-09-12 15:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-12 15:09:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amye Scavarda 2017-09-12 00:55:58 UTC
Description of problem:
http://gluster.org/download/ redirects to https://www.gluster.org/download-server-is-down-building-a-replacement/


Expected results:
We probably don't need to have this anymore. Pretty sure this is over on the redirect side and not the WP side.

Comment 1 M. Scherer 2017-09-12 12:16:21 UTC
I beg to differ:

$ curl -v https://www.gluster.org/download/ 
* About to connect() to www.gluster.org port 443 (#0)
*   Trying 35.197.52.145...
* Connected to www.gluster.org (35.197.52.145) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
* Server certificate:
* 	subject: CN=www.gluster.org
* 	start date: août 31 14:26:00 2017 GMT
* 	expire date: nov. 29 14:26:00 2017 GMT
* 	common name: www.gluster.org
* 	issuer: CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US
> GET /download/ HTTP/1.1
> User-Agent: curl/7.29.0
> Host: www.gluster.org
> Accept: */*
> 
< HTTP/1.1 301 Moved Permanently
< Server: nginx
< Date: Tue, 12 Sep 2017 12:13:01 GMT
< Content-Type: text/html; charset=UTF-8
< Content-Length: 0
< Connection: keep-alive
< Keep-Alive: timeout=20
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Location: https://www.gluster.org/download-server-is-down-building-a-replacement/
< X-Cacheable: non200
< Cache-Control: max-age=600, must-revalidate
< Accept-Ranges: bytes
< X-Cache: MISS
< X-Pass-Why: 
< X-Cache-Group: normal
< X-Type: default
< 
* Connection #0 to host www.gluster.org left intact


That's www.gluster.org, on 35.197.52.145 (GCE IP) who do a 302 redirect using nginx, so that's wpengine side.

$ host gluster.wpengine.com
gluster.wpengine.com has address 35.197.52.145

Comment 2 M. Scherer 2017-09-12 12:31:38 UTC
I suspect that's a prefix matching plugin or something, since https://www.gluster.org/downlo also redirect to the wrong page.

Comment 3 M. Scherer 2017-09-12 13:47:11 UTC
So I started to look for the plugins installed, and out of the 7 there, none did look like a culprit.

So after asking to a friend serving as a teddy bear, he pointed me on https://wordpress.stackexchange.com/questions/92103/disable-wordpress-url-auto-complete

There is a plugin for that:

https://wordpress.org/plugins/disable-url-autocorrect-guessing/

Comment 4 Amye Scavarda 2017-09-12 15:09:25 UTC
Resolved by making a /download page that can redirect as needed back to /install.
Thanks for the hunting!


Note You need to log in before you can comment on or make changes to this bug.