Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1490669 - [upstream] : SUI : Custom button on service shows error on submitting request
Summary: [upstream] : SUI : Custom button on service shows error on submitting request
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard: ssui
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-12 01:02 UTC by Shveta
Modified: 2017-12-05 15:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-13 16:30:37 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
submit request error (187.84 KB, image/png)
2017-09-12 01:02 UTC, Shveta
no flags Details

Description Shveta 2017-09-12 01:02:34 UTC
Created attachment 1324649 [details]
submit request error

Description of problem: 


Version-Release number of selected component (if applicable):
master.20170908132343_bf64a63

How reproducible:


Steps to Reproduce:
1. Create a button on service in OPS UI
2. Order a service
3. in SUI , click on the service button and then submit request. 
See Error. 

Actual results:


Expected results:


Additional info:
Looks like api error from the console logs .
Appliance : https://10.8.199.32/ui/service

Comment 2 Jillian Tullo 2017-10-16 12:32:43 UTC
Hi Shveta-

After looking at the screenshot, it looks like it's getting a 404 because the SUI is pointing to /api/null/:id, which is an invalid request.

Can you please check with them on this one?

Thank you!
- Jillian

Comment 3 Shveta 2017-11-13 16:30:37 UTC
Not seeing this issue anymore.
5.9.0.8.20171109215303_ed87902


Note You need to log in before you can comment on or make changes to this bug.