Bug 1490742 - Hot-unplugging a vhost network device leaks references to VFIOPCIDevice's [rhel-7.4.z]
Summary: Hot-unplugging a vhost network device leaks references to VFIOPCIDevice's [rh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Alex Williamson
QA Contact: Yanan Fu
URL:
Whiteboard:
Depends On: 1489670
Blocks: 1498135 1498139 1498140 1498141 1498145 1498146 1498155
TreeView+ depends on / blocked
 
Reported: 2017-09-12 07:34 UTC by Oneata Mircea Teodor
Modified: 2017-10-16 10:45 UTC (History)
17 users (show)

Fixed In Version: qemu-kvm-rhev-2.9.0-16.el7_4.7
Doc Type: Bug Fix
Doc Text:
Hot-unplugging Virtual Function I/O (VFIO) devices previously failed when performed after hot-unplugging a vhost network device. This update fixes the underlying code, and the VFIO device is unplugged correctly in the described circumstances.
Clone Of: 1489670
: 1498135 1498139 1498140 1498141 1498145 1498146 1498155 (view as bug list)
Environment:
Last Closed: 2017-10-16 10:45:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1371930 high CLOSED i40e: "x-req" can not work normally when unbind PF form host or unload PF's driver 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2017:2891 normal SHIPPED_LIVE qemu-kvm-rhev bug fix update 2017-10-16 14:44:54 UTC

Description Oneata Mircea Teodor 2017-09-12 07:34:46 UTC
This bug has been copied from bug #1489670 and has been proposed to be backported to 7.4 z-stream (EUS).

Comment 7 Yanan Fu 2017-09-29 11:20:05 UTC
Confirmed with slopezpa@redhat.com, refer comment 15 in bz 1489670, scenario 2 is wrong.

Move to VERIFIED accordingly.

Comment 9 errata-xmlrpc 2017-10-16 10:45:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2891


Note You need to log in before you can comment on or make changes to this bug.