Bug 149080 - clvmd-gulm locking is broken
clvmd-gulm locking is broken
Status: CLOSED DUPLICATE of bug 146056
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 10:37 EST by Christine Caulfield
Modified: 2010-01-11 23:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2005-02-18 10:37:04 EST
Description of problem:
The gulm module of clvm locking cannot cope with conversions - it
assumes all locks are new ones and so locks can get left around
because of the horrible hack it uses for mapping DLM lock modes onto
gulm ones.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. vgchange -an; vgchange -ay one one node
2. lvextend on that node
3. lvreduce on that node
    

Actual Results:  lvreduce hangs 

Expected Results:  non-hanging

Additional info:
Comment 1 Christine Caulfield 2005-02-21 09:37:59 EST
Need to maniplate both locks when changing modes.

There's still something up with clvmd via gulm - I need Mike's help.

Checking in daemons/clvmd/clvmd-gulm.c;
/cvs/lvm2/LVM2/daemons/clvmd/clvmd-gulm.c,v  <--  clvmd-gulm.c
new revision: 1.10; previous revision: 1.9
done
Comment 2 Christine Caulfield 2005-02-28 10:48:38 EST

*** This bug has been marked as a duplicate of 146056 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:08:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.