Bug 149083 - window list is BROKEN, groups too early, etc.
window list is BROKEN, groups too early, etc.
Status: CLOSED DUPLICATE of bug 148915
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 11:06 EST by Trever Adams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2005-02-18 11:06:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
Due to recent menu upgrades (read breackages) I have had to change to the silly two panel format. I removed all my settings for panel and metacity.

Now, my windows are grouped if I have more than three open, I have played with default settings of 4096 max size to about 600. It doesn't change a thing.

Now when I click on a window in the window list, it isn't raised unless (and then only sometimes) there are no grouped windows. This used to work whether or not the windows were grouped.

Possibly related:
* Windows don't automatically popup and take focus when they are new like they used to.
* Window titles, such as terminal (which is the main culprit in the previous issue bullet), often stay bold for some rediculous period of time.
* Windows seem to change order in the window list. This is bad, once there, they shouldn't change order... especially now that they are all on one line.


Version-Release number of selected component (if applicable):
gnome-panel-2.9.91-2

How reproducible:
Always

Steps to Reproduce:
1. Please, see ultra thorough description above
2.
3.
  

Actual Results:  Please, see ultra thorough description above

Additional info:
Comment 1 Mark McLoughlin 2005-02-22 06:54:58 EST
Okay, there's a lot of verbage here which makes it very difficult to
figure out what bug you're trying to describe, but I think its the
"clicking on grouped windows doesn't raise" bug.

*** This bug has been marked as a duplicate of 148915 ***
Comment 2 Trever Adams 2005-02-22 12:42:29 EST
It is more than just it doesn't raise. The grouping happens WAY TOO
EARLY. You set the maximum width to 4096 (was the default), and yet
after three windows being opened, they grouped. Not only that, but the
window list compresses the buttons for them long before they need to
be compressed (shrunk, whatever).

This doesn't happen, I don't believe, with the single larger panel
(which I had been using until the recent forced change (Due to menu
changes)).


As for the not raising, yes, that seems to be the one you marked this
as a duplicate of. However, it is not a duplicate of that, that was a
sub, possibly related, bug.
Comment 3 Red Hat Bugzilla 2006-02-21 14:08:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.