Bug 1490837
| Summary: | iptables-restore calls fail acquiring 'xlock' with iptables | |||
|---|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Arie Bregman <abregman> | |
| Component: | openstack-neutron | Assignee: | Ihar Hrachyshka <ihrachys> | |
| Status: | CLOSED ERRATA | QA Contact: | Toni Freger <tfreger> | |
| Severity: | urgent | Docs Contact: | ||
| Priority: | urgent | |||
| Version: | 8.0 (Liberty) | CC: | amuller, ccollett, chrisw, ihrachys, nyechiel, sclewis, srevivo | |
| Target Milestone: | zstream | Keywords: | AutomationBlocker, Triaged, ZStream | |
| Target Release: | 8.0 (Liberty) | |||
| Hardware: | Unspecified | |||
| OS: | Unspecified | |||
| Whiteboard: | ||||
| Fixed In Version: | openstack-neutron-7.2.0-23.el7ost | Doc Type: | Bug Fix | |
| Doc Text: |
Previously, iptables_hybrid and iptables firewall drivers were not compatible with the new iptables package shipped with RHEL. The new iptables package introduced file locking when calling the iptables-restore command. Consequently, attempts to configure firewall rules using iptables_hybrid or iptables firewall drivers would sometimes fail.
With this update, the iptables file is correctly locked when calling iptables-restore inside the iptables_hybrid or iptables firewall drivers. As a result, no errors occur when applying firewall rules to neutron ports.
|
Story Points: | --- | |
| Clone Of: | ||||
| : | 1490839 (view as bug list) | Environment: | ||
| Last Closed: | 2017-11-29 15:59:16 UTC | Type: | Bug | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | ||||
| Bug Blocks: | 1490839, 1490843 | |||
|
Description
Arie Bregman
2017-09-12 11:10:03 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2017:3281 |