Bug 1490898 (CVE-2017-2923) - CVE-2017-2923 freexl: Heap-based buffer overflow in the read_biff_next_record function
Summary: CVE-2017-2923 freexl: Heap-based buffer overflow in the read_biff_next_record...
Keywords:
Status: NEW
Alias: CVE-2017-2923
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1490901 1490902
Blocks: 1490900
TreeView+ depends on / blocked
 
Reported: 2017-09-12 12:45 UTC by Andrej Nemec
Modified: 2019-09-29 14:22 UTC (History)
5 users (show)

Fixed In Version: freexl 1.0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Andrej Nemec 2017-09-12 12:45:02 UTC
An exploitable heap based buffer overflow vulnerability exists in the read_biff_next_record function of FreeXL 1.0.3. A specially crafted XLS file can cause a memory corruption resulting in remote code execution. An attacker can send malicious XLS file to trigger this vulnerability.

External References:

https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0430

Comment 1 Andrej Nemec 2017-09-12 12:48:38 UTC
Created freexl tracking bugs for this issue:

Affects: epel-all [bug 1490901]
Affects: openshift-1 [bug 1490902]


Note You need to log in before you can comment on or make changes to this bug.