Bug 149099 - Kernel upgrade breaks sound output, AC97 controller
Kernel upgrade breaks sound output, AC97 controller
Status: CLOSED DUPLICATE of bug 144742
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 13:13 EST by Eric Pare
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 22:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Pare 2005-02-18 13:13:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
There have been a few kernel updates since kernel-2.6.9-1.724_FC3. 
Since a while, there were updates that broke something in sound output
or in my audio driver.  I can't recall if the problem exists between
these kernel versions.  My only assertion is that the problem does not
exist with the old kernel version kernel-2.6.9-1.724_FC3, and that it
does with the latest kernel version kernel-2.6.10-1.766_FC3.

If I boot on kernel-2.6.10-1.766_FC3, my soundcard is detected and the
snd_ac97_codec module looks like it's loaded properly, but no sound
comes out, as if 'mute' was on.  I did not check 'all' of the modules
that should be loaded (contact me with specific questions that arise).

Opening Kmix just doesn't show anything that is muted.  Output used is
arts.  Booting with older kernel I kept (kernel-2.6.9-1.724_FC3)
solves the problem. 

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot new kernel
2. Launch Xmms and try to play something
3. Launch anything else, a WAV file somewhere on the disk
    

Actual Results:  Xmms shows that it plays, but no sound is outputted
at all.  Driver is loaded - as if kernel modules were loaded all okay.
 Playing a WAV with noatun simulates that it plays as if 'mute' was
on, nothing outputted.

Expected Results:  Make some noise!

Additional info:

lspci with working kernel :
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host
Bridge (rev 04)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP
Bridge (rev 04)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp. 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4-M) IDE Controller
(rev 03)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
Mobility M6 LY
02:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus
Controller
02:08.0 Ethernet controller: Intel Corp. 82801DB PRO/100 VE (MOB)
Ethernet Controller (rev 83)


lsmod with working kernel :
Module                  Size  Used by
md5                     4033  1
ipv6                  230529  6
parport_pc             24705  0
lp                     11565  0
parport                36745  2 parport_pc,lp
autofs4                23109  0
i2c_dev                10305  0
i2c_core               22081  1 i2c_dev
sunrpc                156709  1
ds                     17349  2
ipt_REJECT              6593  1
ipt_state               1857  1
ip_conntrack           40565  1 ipt_state
iptable_filter          2753  1
ip_tables              15937  3 ipt_REJECT,ipt_state,iptable_filter
dm_mod                 54229  0
sd_mod                 17217  0
button                  6481  0
battery                 8517  0
ac                      4805  0
usb_storage            61193  0
scsi_mod              120141  2 sd_mod,usb_storage
joydev                  9345  0
yenta_socket           19009  0
pcmcia_core            59785  2 ds,yenta_socket
uhci_hcd               31065  0
ehci_hcd               30661  0
snd_intel8x0m          18057  0
snd_intel8x0           34829  1
snd_ac97_codec         63761  2 snd_intel8x0m,snd_intel8x0
snd_pcm_oss            48377  0
snd_mixer_oss          17985  1 snd_pcm_oss
snd_pcm                94921  4 snd_intel8x0m,snd_intel8x0,snd_pcm_oss
snd_timer              28997  1 snd_pcm
snd_page_alloc          9673  3 snd_intel8x0m,snd_intel8x0,snd_pcm
gameport                4801  1 snd_intel8x0
snd_mpu401_uart         8769  1 snd_intel8x0
snd_rawmidi            26085  1 snd_mpu401_uart
snd_seq_device          8137  1 snd_rawmidi
snd                    53541  11
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_
mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               9889  1 snd
e100                   39365  0
mii                     4673  1 e100
ext3                  116553  2
jbd                    71257  1 ext3
Comment 1 Warren Togami 2005-02-18 22:32:58 EST

*** This bug has been marked as a duplicate of 144742 ***

Note You need to log in before you can comment on or make changes to this bug.