Bug 1491045 - AArch64 install fails with 'The package 'grub2' is required for this installation.'
Summary: AArch64 install fails with 'The package 'grub2' is required for this installa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: ARMTracker F27BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-09-12 21:50 UTC by Paul Whalen
Modified: 2019-07-31 17:56 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-25 18:08:03 UTC


Attachments (Terms of Use)
packaging.log (6.72 KB, text/plain)
2017-09-12 21:51 UTC, Paul Whalen
no flags Details
storage.log (174.19 KB, text/plain)
2017-09-13 14:00 UTC, Paul Whalen
no flags Details
program.log (45.75 KB, text/plain)
2017-09-13 14:00 UTC, Paul Whalen
no flags Details
lvm.log (143.63 KB, text/plain)
2017-09-13 14:01 UTC, Paul Whalen
no flags Details
ifcfg.log (6.23 KB, text/plain)
2017-09-13 14:02 UTC, Paul Whalen
no flags Details
hawkey.log (762 bytes, text/plain)
2017-09-13 14:02 UTC, Paul Whalen
no flags Details
dnf.librepo.log (11.15 KB, text/plain)
2017-09-13 14:03 UTC, Paul Whalen
no flags Details
anaconda.log (46.49 KB, text/plain)
2017-09-13 14:03 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2017-09-12 21:50:11 UTC
Description of problem:
Installation of Fedora-27-20170912.n.0 on aarch64 fails with the error:

The package 'grub2' is required for this installation. This package does not
exist. This is a fatal error and installation will be aborted.

Version-Release number of selected component (if applicable):
anaconda-27.20.1-1.fc27

Comment 1 Paul Whalen 2017-09-12 21:51:06 UTC
Created attachment 1325030 [details]
packaging.log

Comment 2 Paul Whalen 2017-09-12 21:56:32 UTC
Proposing as a Freeze Exception for F27 Beta, this breaks installations on AArch64. Criteria "When using a dedicated installer image, the installer must be able to complete an installation"

Comment 3 Peter Robinson 2017-09-12 21:58:48 UTC
This was a problem 2 weeks ago and was fixed during flock. It seems it's regressed again :(

Comment 4 Jiri Konecny 2017-09-13 06:49:11 UTC
Could you please provides us all the logs from the installation.

Thanks

Comment 5 Paul Whalen 2017-09-13 14:00:13 UTC
Created attachment 1325469 [details]
storage.log

Comment 6 Paul Whalen 2017-09-13 14:00:43 UTC
Created attachment 1325470 [details]
program.log

Comment 7 Paul Whalen 2017-09-13 14:01:24 UTC
Created attachment 1325472 [details]
lvm.log

Comment 8 Paul Whalen 2017-09-13 14:02:06 UTC
Created attachment 1325475 [details]
ifcfg.log

Comment 9 Paul Whalen 2017-09-13 14:02:35 UTC
Created attachment 1325476 [details]
hawkey.log

Comment 10 Paul Whalen 2017-09-13 14:03:03 UTC
Created attachment 1325477 [details]
dnf.librepo.log

Comment 11 Paul Whalen 2017-09-13 14:03:23 UTC
Created attachment 1325478 [details]
anaconda.log

Comment 12 Jiri Konecny 2017-09-14 07:54:07 UTC
We are providing grub2 package in Anaconda because of bootloader:

20:53:09,742 DBG payload: added package requirement 'chrony' for ntp, strong=False
20:53:09,744 DBG payload: added package requirement 'grub2-efi-aa64' for bootloader, strong=True
20:53:09,745 DBG payload: added package requirement 'shim-aa64' for bootloader, strong=True
20:53:09,746 DBG payload: added package requirement 'efibootmgr' for bootloader, strong=True
20:53:09,748 DBG payload: added package requirement 'grub2' for bootloader, strong=True
20:53:09,749 DBG payload: added package requirement 'grub2-tools' for bootloader, strong=True



However, I'm not quite sure if this is intentional behavior and the grub2 should be a provides of some other package in aarch64. Could you please bring some more light to this Peter?

Comment 13 Kamil Páral 2017-09-18 17:08:32 UTC
Discussed at blocker review meeting [1]:

AcceptedFreezeException - This bug violates the criterion "When using a dedicated installer image, the installer must be able to complete an installation" for AArch64 architecture.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-18

Comment 14 Fedora Update System 2017-09-21 13:06:00 UTC
grub2-2.02-18.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7c50b72f8f

Comment 15 Fedora Update System 2017-09-21 23:59:24 UTC
grub2-2.02-18.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7c50b72f8f

Comment 16 Fedora Update System 2017-09-25 18:08:03 UTC
grub2-2.02-18.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.