Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1491100 - Install failed due to "openshift_hosted_registry_storage_azure_blob_realm" undefined
Summary: Install failed due to "openshift_hosted_registry_storage_azure_blob_realm" un...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.9.0
Assignee: Scott Dodson
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-13 05:05 UTC by Wenkai Shi
Modified: 2018-03-28 14:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When configuring the registry for Azure Blob storage the default realm of 'core.windows.net is specified, if you wish to change this please set openshift_hosted_registry_storage_azure_blob_realm to the value you wish to use.
Clone Of:
Environment:
Last Closed: 2018-03-28 14:06:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 0 None None None 2018-03-28 14:06:48 UTC

Description Wenkai Shi 2017-09-13 05:05:22 UTC
Description of problem:
Install OCP with azure_blob as registry beck end storage, according to https://github.com/docker/docker.github.io/blob/master/registry/storage-drivers/azure.md , the parameter "openshift_hosted_registry_storage_azure_blob_realm" should have a default value "core.windows.net" when customer didn't set it.

Version-Release number of the following components:
openshift-ansible-3.7.0-0.125.0.git.0.91043b6.el7

How reproducible:
100%

Steps to Reproduce:
1. Install OCP with azure_blob as registry beck end storage
# cat hosts
...
openshift_hosted_registry_storage_kind=object
openshift_hosted_registry_storage_provider=azure_blob
openshift_hosted_registry_storage_azure_blob_accountname=<hide>
openshift_hosted_registry_storage_azure_blob_accountkey=<hide>
openshift_hosted_registry_storage_azure_blob_container=<hide>
...
2.
3.

Actual results:
# ansible-playbook -i hosts -v /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml
...
TASK [openshift_hosted : Ensure the registry secret exists] ********************
Wednesday 13 September 2017  02:43:12 +0000 (0:00:00.028)       0:13:34.723 *** 
fatal: [master-1.example.com]: FAILED! => {
    "failed": true
}

MSG:

the field 'args' has an invalid value, which appears to include a variable that is undefined. The error was: 'openshift_hosted_registry_storage_azure_blob_realm' is undefined

The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_hosted/tasks/registry/storage/object_storage.yml': line 5, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: Ensure the registry secret exists
  ^ here
...

Expected results:
openshift_hosted_registry_storage_azure_blob_realm should set "core.windows.net" as default value.

Additional info:

Comment 4 Wenkai Shi 2018-01-29 04:31:07 UTC
Verified with version openshift-ansible-3.9.0-0.31.0.git.0.e0a0ad8.el7.default value set and installer works as expect.

Comment 7 errata-xmlrpc 2018-03-28 14:06:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489


Note You need to log in before you can comment on or make changes to this bug.