Bug 1491125 - Memory widget on dashboard shows incorrect usage
Summary: Memory widget on dashboard shows incorrect usage
Keywords:
Status: CLOSED DUPLICATE of bug 1490272
Alias: None
Product: ovirt-engine-dashboard
Classification: oVirt
Component: General
Version: 1.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Shirly Radco
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-13 07:07 UTC by RamaKasturi
Modified: 2017-10-17 11:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-17 11:08:36 UTC
oVirt Team: Metrics
Embargoed:


Attachments (Terms of Use)
Memory widget on the dashboard (151.18 KB, image/png)
2017-09-13 07:07 UTC, RamaKasturi
no flags Details
attaching screenshot for memory widget (164.63 KB, image/png)
2017-10-17 09:54 UTC, RamaKasturi
no flags Details

Description RamaKasturi 2017-09-13 07:07:09 UTC
Created attachment 1325239 [details]
Memory widget on the dashboard

Description of problem:
Memory used on the dashboard shows as 0.0 GiB used though actual memory consumption on all the hosts together is 53GiB.

Host 1:
============================
[root@rhsqa-grafton1 ~]# free -m
              total        used        free      shared  buff/cache   available
Mem:         257677       39352      177774          35       40550      217277
Swap:          4095           0        4095

Host2 :
================================
[root@rhsqa-grafton2 ~]# free -m
              total        used        free      shared  buff/cache   available
Mem:         257677       12772      204045          26       40859      243871
Swap:          4095           0        4095

Host3:
========================================
[root@rhsqa-grafton3 ~]# free -m
              total        used        free      shared  buff/cache   available
Mem:         257677        2551      253686          25        1439      254182
Swap:          4095           0        4095

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.6.2-0.1.el7
ovirt-engine-dashboard-1.1.2-1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install HCI with latest RHV-M 4.1.6.2 
2. 
3.

Actual results:
Though actual usage of memory is 53 GiB ovirt dashboard memory widget shows 0.00 percent and on mouse hovering on that shows 100 % GiB available.

Expected results:
Memory widget on the dashboard should show correct usage.

Additional info:

Comment 1 RamaKasturi 2017-09-13 07:11:03 UTC
engine and dwh logs are present in the link below.
====================================================
http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/HC/1491125/

Comment 2 Yaniv Kaul 2017-09-13 07:14:51 UTC
Shirly, please take a look, especially in the DWH logs, what are:
Exception in component tJDBCInput_1
java.lang.NumberFormatException: For input string: "6.1"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.lang.Integer.parseInt(Integer.java:580)
	at java.lang.Integer.parseInt(Integer.java:615)
	at ovirt_engine_dwh.minimalversioncheck_4_1.MinimalVersionCheck.tJDBCInput_1Process(MinimalVersionCheck.java:1225)
	at ovirt_engine_dwh.minimalversioncheck_4_1.MinimalVersionCheck.tJDBCConnection_2Process(MinimalVersionCheck.java:782)
	at ovirt_engine_dwh.minimalversioncheck_4_1.MinimalVersionCheck.tJDBCConnection_1Process(MinimalVersionCheck.java:657)
	at ovirt_engine_dwh.minimalversioncheck_4_1.MinimalVersionCheck.runJobInTOS(MinimalVersionCheck.java:3089)
	at ovirt_engine_dwh.minimalversioncheck_4_1.MinimalVersionCheck.runJob(MinimalVersionCheck.java:2853)
	at ovirt_engine_dwh.historyetl_4_1.HistoryETL.tRunJob_2Process(HistoryETL.java:8163)
	at ovirt_engine_dwh.historyetl_4_1.HistoryETL$3.run(HistoryETL.java:11674)
2017-09-13 02:10:18|a1AWZP|bZY3Rb|bZY3Rb|OVIRT_ENGINE_DWH|MinimalVersionCheck|Default|6|Java Exception|tJDBCInput_1|java.lang.NumberFormatException:For input string: "6.1"|1
Exception in component tRunJob_2
java.lang.RuntimeException: Child job running failed
	at ovirt_engine_dwh.historyetl_4_1.HistoryETL.tRunJob_2Process(HistoryETL.java:8186)
	at ovirt_engine_dwh.historyetl_4_1.HistoryETL$3.run(HistoryETL.java:11674)
2017-09-13 02:10:18|bZY3Rb|bZY3Rb|bZY3Rb|OVIRT_ENGINE_DWH|HistoryETL|Default|6|Java Exception|tRunJob_2|java.lang.RuntimeException:Child job running failed|1
2017-09-13 02:10:18|ETL Service Stopped

Comment 3 Shirly Radco 2017-10-16 07:47:57 UTC
Please upgrade to latest 4.1.z.
This issue was resolved in bug 1490272

Comment 4 Shirly Radco 2017-10-16 07:49:34 UTC
Since the dwh fails to load, no data is collected. This is why the data is missing from the dashboard.

Comment 5 RamaKasturi 2017-10-17 09:53:00 UTC
Hi shirly,

     I see that memory widget on the dashboard reports the utilization correctly.

Host1:
======

[root@yarrow ~]# free -m
              total        used        free      shared  buff/cache   available
Mem:          96268       17751       78262          34         255       77998
Swap:          4095           0        4095


Host2:
================
[root@tettnang ~]# free -m
              total        used        free      shared  buff/cache   available
Mem:          96268        4074       91933          34         260       91672
Swap:          4095           0        4095

Host3:
============================
[root@zod ~]# free -m
              total        used        free      shared  buff/cache   available
Mem:          96268        4085       91928          34         255       91666
Swap:          4095           0        4095

Below are the versions of RHV-M and dwh:
=======================================
RHV-M : Red Hat Virtualization Manager Version: 4.1.7.3-0.1.el7
dwh version : ovirt-engine-dwh-4.1.7-1.el7ev.noarch

Thanks
kasturi

Comment 6 RamaKasturi 2017-10-17 09:54:29 UTC
Created attachment 1339640 [details]
attaching screenshot for memory widget

Comment 7 RamaKasturi 2017-10-17 11:08:36 UTC

*** This bug has been marked as a duplicate of bug 1490272 ***


Note You need to log in before you can comment on or make changes to this bug.