Bug 149113 - gcc-debuginfo includes broken links to /usr/src/build
gcc-debuginfo includes broken links to /usr/src/build
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 16:11 EST by Luca Barbieri
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-12 10:05:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Barbieri 2005-02-18 16:11:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
/usr/src/debug/gcc-3.4.3-20050210/obj-i386-redhat-linux/i386-redhat-linux/libstdc++-v3/include
contains broken links to files in
/usr/src/build/520092-i386/BUILD/gcc-3.4.3-20050210/libstdc++-v3/include


Version-Release number of selected component (if applicable):
gcc-debuginfo-3.4.3-19

How reproducible:
Always
Comment 1 Jakub Jelinek 2005-02-21 10:20:04 EST
I believe this needs to be fixed in /usr/lib/rpm/find-debuginfo.sh, because
I guess gcc is not the only package that has absolute symlinks in its build dir
and even if it is a relative symlink to otherwise unreferenced file, *-debuginfo
package might contain just the symlink and not what it actually points to.

I think there are 2 possible solutions, one is replace -pd0m with -pd0mL
in find-debuginfo.sh (and optionally run hardlink on the
${RPM_BUILD_ROOT}/usr/src/debug tree to kill duplicates), or after copying
the files keep cycling through the symlinks in that tree and for absolute ones
to $RPM_BUILD_ROOT replace them with symlinks into /usr/src/debug/* and copy
whatever they point to into the tree as well.
Comment 2 Jeff Johnson 2006-02-12 10:05:49 EST
I've added the L option to tpm cvs, should be in rpm-4.4.5-0.10 when built.

The real problem with debuginfo is the rewrite of paths in elf headers without
reallocating the header, thereby preventing rpmbuild from producing -debuginfo
packages when configured on build paths shorter than /usr/src/debug. The eventual
fix for that will be to stop producing -debuginfo packages with rpmbuild.

Note You need to log in before you can comment on or make changes to this bug.