Bug 149115 - RHEL3: capturing oopses via serial console
RHEL3: capturing oopses via serial console
Status: CLOSED DUPLICATE of bug 149018
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: dff
kernel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 16:50 EST by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 19:47:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2005-02-18 16:50:32 EST
*** This bug has been split off bug 149018 ***

------- Original comment by Jure Pečar on 2005.02.17 17:45 -------

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; rv:1.7.3) Gecko/20041014 Firefox/0.10.1

Description of problem:
I have all my servers' serial consoles connected to one machine with many serial
ports, where I can access them via minicom. I also have watchdog modules
configured on servers to autoreboot them in case of problems.

Every now and then some server goes down with an oops. My idea for this serial
console setup was simplified oops capturing, but there's a problem: when
watchdog reboots the server, bios actually redraws the whole screen, deleting
all the oops info. So I was thinking ... Could it be possible to add a simple
loop to the oops printing function that would print a number of newlines after
the oops info, where number would be taken as a kernel boot line parameter? So
that bios would redraw over already blank screen and I could just scroll minicom
buffer up to get the oops.

Version-Release number of selected component (if applicable):
any kernel

How reproducible:
Always

Steps to Reproduce:
1. set up a server with console on serial port and watchdog timer to reboot it
2. make someting to oops it
3. watch the console in minicom and observe bios overwriting oops data
  

Additional info:

I don't know if this can be acomplished with some minicom setting or possibly
with using something else than minicom for serial terminal. If it is, I'd like
to know how to do it. Afterall, I'd like to see where my machines are oopsing
and figure out why.
Comment 1 Ernie Petrides 2005-10-06 19:47:38 EDT
Converting back to BZ and closing as dup of source BZ.

*** This bug has been marked as a duplicate of 149018 ***

Note You need to log in before you can comment on or make changes to this bug.