Bug 149120 - up2date kernel - No module ieee1394 found for kernel - aborting
up2date kernel - No module ieee1394 found for kernel - aborting
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 17:17 EST by Robert Buffington
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-06 19:42:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Buffington 2005-02-18 17:17:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
command: up2date kernel kernel-unsupported

result: No module ieee1394 found for kernel 2.4.21-27.0.2.EL, aborting. mkinitrd failed.

kernel gets installed, but no grub.conf entry is created after this error.

see details below...

Version-Release number of selected component (if applicable):
kernel 2.4.21-27.0.2.EL

How reproducible:
Always

Steps to Reproduce:
1. install kernel-unsupported
2. connect firewire drive
3. run kudzu to configure firewire drive
4. ieee1394, ohci1394, sbp2 modules get placed in /etc/modules.conf
5. update kernel kernel-unsupported with up2date
6. kernel script tries to mkinitrd with ieee1394 support.
7. script fails because ieee1394 is in kernel-unsupported.
8. kernel gets installed, but /etc/grub.conf does not get updated.
  

Expected Results:  kernel script should realize that ieee1394 is part of kernel-unsupported and should either ignore ieee1394 modules or look for ieee1394 in kernel-unsupported modules (which means that kernel would have a dependency on kernel-unsupported in this case.)

Additional info:
Comment 2 Ernie Petrides 2005-06-06 19:42:28 EDT
Hello, Robert.  Please upgrade the kernel-unsupported package before the
kernel package when using unsupported modules.  Then things should work
properly.

Note You need to log in before you can comment on or make changes to this bug.