This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 149135 - ntpd startup fails on boot
ntpd startup fails on boot
Status: CLOSED DUPLICATE of bug 154759
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Ryska
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 20:36 EST by JCC
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-12 11:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JCC 2005-02-18 20:36:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
On boot up of FC3, the ntpd startup fails.  After boot up is complete, from a terminal window, as root type: /etc/rc.d/init.d/ntpd restart, and ntp starts successfully.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Cold boot FC3
2.
3.
  

Actual Results:  ntpd fails to start with the following message:

ntpd: Synchronizing with time server:      [failed]



Expected Results:  ntpd: Synchronizing with time server:                      [  OK  ]

Additional info:
Comment 1 Davide Bolcioni 2005-06-03 13:56:05 EDT
I attempted a strace: ntp-4.2.0.a.20040617-4 uncerimoniously segfaults:

...
8042  rt_sigaction(SIGSYS, {0x8c53a0, [], SA_RESTORER, 0x2f48c8}, {SIG_DFL}, 8) = 0
8042  rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
8042  adjtimex({modes=61, offset=0, freq=0, maxerror=16, esterror=16, status=64,
constant=0, precision=1, tolerance=33554432, time={1117821155, 463315}}) = 5
8042  rt_sigaction(SIGSYS, {SIG_DFL}, NULL, 8) = 0
8042  --- SIGSEGV (Segmentation fault) @ 0 (0) ---
Comment 2 Frank Ch. Eigler 2005-06-12 11:16:54 EDT

*** This bug has been marked as a duplicate of 154759 ***

Note You need to log in before you can comment on or make changes to this bug.