Bug 1491367 - System update with dnfdragora fails with segfault (SIGSEGV)
Summary: System update with dnfdragora fails with segfault (SIGSEGV)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-13 15:14 UTC by Basic Six
Modified: 2019-01-24 14:15 UTC (History)
4 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:27:39 UTC


Attachments (Terms of Use)
system messages during dnfdragora crash (7.68 KB, text/plain)
2017-09-13 15:14 UTC, Basic Six
no flags Details
system messages during dnfdragora crash (6.16 KB, text/plain)
2017-09-13 15:24 UTC, Basic Six
no flags Details
dnfdragora not working (meaningless error) (47.37 KB, image/png)
2017-09-19 12:31 UTC, Basic Six
no flags Details
dnfdragora window not updating (41.31 KB, image/png)
2019-01-24 14:15 UTC, Basic Six
no flags Details

Description Basic Six 2017-09-13 15:14:26 UTC
Created attachment 1325503 [details]
system messages during dnfdragora crash

Description of problem:

After upgrading to Fedora 26 using gnome-software, the package tool called "dnfdragora" has been installed.
After trying to use it to update the system, it crashed.



Version-Release number of selected component (if applicable):

Fedora 26
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26.noarch
dnfdragora-1.0.1-5.git20170505.2a3b056.fc26.noarch



How reproducible:

Not sure.



Steps to Reproduce:
1. Click dragora icon in tray area and select "Update" option.
2. Check all items in list (assuming they're all updates) and start the update process by clicking "Apply".
3. Observe window disappear.



Actual results:

The new Fedora updater crashes.



Expected results:

The new Fedora updater should work.



Additional info:

The Why not keep gnome-software, apper or gpk-update-viewer if dnfdragora is not ready yet?
There are three nice graphical update tools (and power users may use dnf on the command line); if there's a new one, it should at least work reliably.

This is the line logged to dmesg:
dnfdragora-upda[1975]: segfault at c8 ip 00007f0b576f386f sp 00007ffd43cc31c0 error 4 in _yui.so[7f0b57679000+157000]

An excerpt from /var/log/messages is attached.

Comment 1 Basic Six 2017-09-13 15:24:18 UTC
Created attachment 1325508 [details]
system messages during dnfdragora crash

Comment 2 Basic Six 2017-09-13 15:48:54 UTC
Side note: dnfdragora has not been installed deliberately. After upgrading to Fedora 26, its icon was shown in the tray area. So it was installed automatically during the upgrade process.

Apparently, dnfdragora is a replacement for yumex/yumex-dnf. Those are still installed:
# rpm -qa | grep yumex
yumex-dnf-4.3.3-4.1.fc26.noarch
yumex-3.0.17-2.fc23.noarch

The old tool called "yumex" fails with this error:
failure: repodata/repomd.xml from virtualbox: [Errno 256] No more mirrors to try.
... [Errno -1] repomd.xml signature could not be verified for virtualbox

The newer yumex-dnf fails with this error (dnf not running at the time):
dnf is locked by another process

Comment 3 Basic Six 2017-09-19 12:31:29 UTC
Created attachment 1327937 [details]
dnfdragora not working (meaningless error)

I thought I'd give dnfdragora another shot. I had previously used apper to update the system, because I didn't want to risk ending up with a broken system if dnfdragora crashes during the process. After apper finished installing updates ("Your system is up to date"), the dnfdragora window I had open still showed the old list of updates, so I opened the tray menu and clicked "Check for updates", thinking that it would then check for updates. Unfortunately, nothing happened and it kept showing that obsolete list of updates. That might be another bug.

Then, I clicked "Check all" and "Apply", just to see what happens when a user tells dnfdragora to install updates, not knowing that these updates are already installed. Please see the attached screenshot for what happened next: A window appeared (titled "BuildTransaction failure", btw. that scares non-admin users), showing "[]" as error message. And the context menu consists of two blank entries. What is it that the program is trying to tell me?

This tool appears way to immature to act as a replacement for apper or gnome-software. Keeping the system up to date is not something that only skilled admins do. Keeping the system up to date is one of the most important features of the operating system. It's very bad to replace such a tool with something incomplete that doesn't work properly.

Comment 4 Fedora Update System 2017-12-29 23:22:10 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 5 Fedora Update System 2017-12-29 23:27:13 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 6 Fedora Update System 2017-12-30 19:54:04 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 7 Fedora Update System 2017-12-30 20:39:50 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 8 Fedora Update System 2017-12-31 21:27:39 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-01-01 22:11:16 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Basic Six 2019-01-24 14:15:38 UTC
Created attachment 1523147 [details]
dnfdragora window not updating

Just a quick note. I don't think it makes sense to reopen the bug ticket because of this.

I thought I'd give dnfdragora another chance, to see if it still crashes. Well, right-click, update didn't do anything, so I opened the window, clicked Apply and boom, I got a notification about a Python exception.

However, it kept running - although the window looks partially frozen and it's not getting updated. See the attached screenshot.

I got this output during the update process (if it's actually updating anything - the window doesn't tell me):

# rpm -qa | grep dragor
dnfdragora-1.1.1-1.fc29.noarch
dnfdragora-1.0.1-13.git20180108.b0e8a66.fc29.noarch
dnfdragora-updater-1.0.1-13.git20180108.b0e8a66.fc29.noarch


Note You need to log in before you can comment on or make changes to this bug.