Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1491491 - texlive-lato, texlive-slantsc missing from RHEL7
Summary: texlive-lato, texlive-slantsc missing from RHEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: texlive-extension
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 975551
TreeView+ depends on / blocked
 
Reported: 2017-09-14 00:29 UTC by Phil Regier
Modified: 2017-09-30 10:19 UTC (History)
3 users (show)

Fixed In Version: texlive-extension-2012-55.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-30 10:19:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Phil Regier 2017-09-14 00:29:38 UTC
Description of problem: LaTeX documents which require the "lato.sty" font cannot build against RHEL7 texlive distribution


Version-Release number of selected component (if applicable): 7.4


How reproducible: Always


Steps to Reproduce:
1. Install RHEL7.4 (or CentOS 7.4) with EPEL to be extra certain that the packages truly are missing altogether.
2. yum provides */lato.sty */slantsc.sty

Actual results:
No matches found


Expected results: (Pasted from Fedora 26; actual package names would be different)
texlive-lato-6:svn24986.2.2-33.fc26.2.noarch : Lato font family and LaTeX support
Repo        : fedora

texlive-slantsc-6:svn25007.2.11-33.fc26.2.noarch : Access different-shaped small-caps fonts
Repo        : fedora


Additional info:
Verified against CentOS 7.4 with EPEL and against my organization's RHEL7 satellite (which may or may not be identical to canonical RHEL7) with EPEL.

texlive-slantsc is only listed here because in F26 it is listed as a dependency for texlive-lato.

Other missing LaTeX packages have been identified here; this report is being treated as a prototype.  If there is a better way to collect/report differences between Fedora TeX Live and RHEL TeX Live please explain so that the next reports will be of higher quality.  Unless a suggestion is made to the contrary, I'll try to report distinct dependency chains separately.

Comment 2 Than Ngo 2017-09-14 13:59:25 UTC
We don't intent to add new packages into rhel-update due to high risk on dependencies. For this Reason we created an new package texlive-extension in EPEL7 which should include the missing packages.

There's an new texlive-extension-2012-55 which now includes the missing texlive-lato and texlive-slantsc.

https://koji.fedoraproject.org/koji/taskinfo?taskID=21860667

I will push it to epel7 update today. If you don't want to wait for new version in epel7-update, please download it from above url and install the missing packages

Please let me know if it works for you.

Thanks

Comment 3 Fedora Update System 2017-09-14 14:23:26 UTC
texlive-extension-2012-55.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e1792be2f4

Comment 4 Phil Regier 2017-09-14 20:56:32 UTC
Thanks so much, Ngo; this is not what I expected but it seems a perfectly reasonable approach.  Unfortunately I don't think I understand fully how texlive-extension is supposed to be acquired and used; I don't see any versions, new or old, in the existing repositories:

https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/t/

Am I looking in the wrong place, or is this an entirely new package?

Comment 5 Phil Regier 2017-09-14 20:58:48 UTC
Actually, I think you can disregard the previous for now; I do see it at

https://dl.fedoraproject.org/pub/epel/7/SRPMS/t/

I need to do a bit more research to verify my initial tests from CentOS/RHEL.

Comment 6 Fedora Update System 2017-09-15 04:17:30 UTC
texlive-extension-2012-55.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e1792be2f4

Comment 7 Phil Regier 2017-09-15 18:52:53 UTC
Thanks again, Ngo.  I think I understand now how the process works; the texlive-extension source package appears to produce a series of RPMs which are actually named according to the established convention.  I downloaded and installed the resulting texlive-lato and texlive-slantsc, and they do solve my problem.

To be clear, for the next few such packages, should I submit against EPEL7 or RHEL7?

Comment 8 Than Ngo 2017-09-18 09:02:27 UTC
Hi Phil, please submit against EPEL7

Comment 10 Fedora Update System 2017-09-30 10:19:26 UTC
texlive-extension-2012-55.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.