Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1491525 - Touchpad tap timestamps can confuse some applications
Summary: Touchpad tap timestamps can confuse some applications
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libinput
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-14 05:25 UTC by Peter Hutterer
Modified: 2018-04-10 11:51 UTC (History)
2 users (show)

Fixed In Version: libinput-1.6.3-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 11:50:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0736 0 None None None 2018-04-10 11:51:59 UTC

Description Peter Hutterer 2017-09-14 05:25:38 UTC
Description of problem:
libinput's timestamps for press and release events on 2-finger touchpad taps are identical. Some applications (e.g. some run under wine) get confused because they cannot order the events correctly. 

This only affects 2 and 3 finger tap, single-finger taps are fine.

Version-Release number of selected component (if applicable):
libinput-1.6.*

How reproducible:
sudo libinput-debug-events --enable-tap

Then do a two-finger tap and observe the timestamps:
-event20  POINTER_BUTTON    +1.43s	BTN_RIGHT (273) pressed, seat count: 1
 event20  POINTER_BUTTON    +1.43s	BTN_RIGHT (273) released, seat count: 0
 event20  POINTER_BUTTON    +2.65s	BTN_RIGHT (273) pressed, seat count: 1
 event20  POINTER_BUTTON    +2.65s	BTN_RIGHT (273) released, seat count: 0
 event20  POINTER_BUTTON    +4.39s	BTN_RIGHT (273) pressed, seat count: 1
 event20  POINTER_BUTTON    +4.39s	BTN_RIGHT (273) released, seat count: 0
 event20  POINTER_BUTTON    +5.46s	BTN_MIDDLE (274) pressed, seat count: 1
 event20  POINTER_BUTTON    +5.46s	BTN_MIDDLE (274) released, seat count: 0


Actual results:
The timestamps should differ slightly between the press and release events.

Comment 1 Peter Hutterer 2017-09-26 03:37:13 UTC
libinput-1.6.3-3.el7 is available in brew

Comment 4 Michael Boisvert 2018-01-09 21:13:32 UTC
Using the reproducer in the description, I am able to see that the timestamps differ slightly between the press and release events:

-event4  POINTER_BUTTON    +1.24s	BTN_RIGHT (273) pressed, seat count: 1
 event4  POINTER_BUTTON    +1.34s	BTN_RIGHT (273) released, seat count: 0
 event4  POINTER_BUTTON    +2.22s	BTN_RIGHT (273) pressed, seat count: 1
 event4  POINTER_BUTTON    +2.29s	BTN_RIGHT (273) released, seat count: 0
 event4  POINTER_BUTTON    +3.15s	BTN_RIGHT (273) pressed, seat count: 1
 event4  POINTER_BUTTON    +3.18s	BTN_RIGHT (273) released, seat count: 0
 event4  POINTER_BUTTON    +6.07s	BTN_MIDDLE (274) pressed, seat count: 1
 event4  POINTER_BUTTON    +6.16s	BTN_MIDDLE (274) released, seat count: 0

Comment 7 errata-xmlrpc 2018-04-10 11:50:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0736


Note You need to log in before you can comment on or make changes to this bug.