Bug 1491560 - 'dnf check' reports spurious "has missing requires of" errors
Summary: 'dnf check' reports spurious "has missing requires of" errors
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-14 07:26 UTC by Valdis Kletnieks
Modified: 2017-10-04 22:26 UTC (History)
5 users (show)

Fixed In Version: dnf-2.7.2-1.fc27 dnf-2.7.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-04 14:24:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2017-09-14 07:26:08 UTC
Description of problem:
'dnf check' on my laptop throws some 70 errors, all of the form 'has missing requires of' - even though there's no actual issue.

For example:
# dnf check
(...)
tkimg-1.4-26.fc27.x86_64 has missing requires of tcl(abi) = 8.6
tkimg-1.4-26.fc27.x86_64 has missing requires of tk >= 8.6
xorg-x11-xinit-1.3.4-16.fc28.x86_64 has missing requires of xhost

Let's investigate that last:

#  rpm -q --whatprovides xhost
xorg-x11-server-utils-7.7-23.fc27.x86_64
# rpm -q --provides xorg-x11-server-utils-7.7-23.fc27.x86_64 | grep xhost
xhost = 1.0.7
# rpm -V xorg-x11-xinit-1.3.4-16.fc28.x86_64 xorg-x11-server-utils-7.7-23.fc27.x86_64
(no issues reported)

(Similar issue for 14 things that complain libglibmm-2.4.so.1()(64bit) is missing, even though RPM thinks it's there...)

So what's going on here? (Already did an 'rpm --drebuilddb' and 'dnf clean' without changing anything)

Version-Release number of selected component (if applicable):
dnf-2.6.3-9.fc28.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jaroslav Mracek 2017-09-14 18:52:20 UTC
Please can you provide an output from dnf:

# dnf repoquery --installed --requires xorg-x11-xinit-1.3.4-16.fc28.x86_64

# dnf repoquery --installed --provides xorg-x11-server-utils-7.7-23.fc27.x86_64

# dnf repoquery --installed xorg-x11-server-utils xorg-x11-xinit

Just to know what dnf sees.

Thanks a lot

Comment 2 Valdis Kletnieks 2017-09-14 19:50:51 UTC
Aha.  Figured it out.

All 70 "missing includes of" errors were because the RPM with the --provides was listed in an exclude= in /etc/dnf/dnf.conf  I have about a dozen RPMs listed for various reasons - mostly when I have some local thing that needs tweaking if an RPM gets updated or I have a local patch against an RPM. 'xhost' was collateral damage because xorg-x11-server-* was excluded so it wouldn't accidentally install and collide with the NVidia driver..

So 'dnf --disableexcludes=all check' works.  It was just totally non-intuitive that 'check' would look at what was accessible via a repo rather than what was actually installed....

Comment 3 Jaroslav Mracek 2017-09-18 09:03:07 UTC
Thanks a lot for information. I create a patch (https://github.com/rpm-software-management/dnf/pull/927) that should solve the issue without ignoring excludes from commandline.

Comment 4 Fedora Update System 2017-10-02 10:36:26 UTC
dnf-plugins-extras-2.0.3-1.fc27 dnf-plugins-core-2.1.4-1.fc27 dnf-2.7.2-1.fc27 libdnf-0.10.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683

Comment 5 Fedora Update System 2017-10-02 10:38:50 UTC
dnf-plugins-extras-2.0.3-1.fc26 dnf-plugins-core-2.1.4-1.fc26 dnf-2.7.2-1.fc26 libdnf-0.10.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065

Comment 6 Fedora Update System 2017-10-02 20:29:25 UTC
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065

Comment 7 Fedora Update System 2017-10-02 21:28:37 UTC
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683

Comment 8 Fedora Update System 2017-10-04 14:24:29 UTC
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-10-04 22:26:20 UTC
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.