Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1491624 - grub2-tools does not belong to a distupgrade repository, causes software-upgrade failure [NEEDINFO]
grub2-tools does not belong to a distupgrade repository, causes software-upgr...
Status: NEW
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-14 05:47 EDT by RudraB
Modified: 2018-04-05 10:14 EDT (History)
30 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
brucemartin10: needinfo? (extras-qa)


Attachments (Terms of Use)

  None (edit)
Description RudraB 2017-09-14 05:47:58 EDT
Description of problem:
While doing upgrade from f26 to f27, I for error, that "none of the providers can be installed" for several packages


Version-Release number of selected component (if applicable):
# dnf --version
2.6.3
  Installed: dnf-0:2.6.3-1.fc26.noarch at Wed 06 Sep 2017 10:43:35 AM GMT
  Built    : Fedora Project at Mon 07 Aug 2017 11:47:37 AM GMT

  Installed: rpm-0:4.13.0.1-7.fc26.x86_64 at Wed 06 Sep 2017 10:42:36 AM GMT
  Built    : Fedora Project at Wed 23 Aug 2017 01:35:47 PM GMT


How reproducible:
Every time

Steps to Reproduce:
1. dnf --refresh upgrade
2. dnf system-upgrade download --refresh --releasever=27
3. ensure you have done dnf --refresh upgrade
Actual results:
dnf system-upgrade download --refresh --releasever=27
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Failed to synchronize cache for repo 'region51-chrome-gnome-shell', disabling.
Failed to synchronize cache for repo 'Dropbox', disabling.
Last metadata expiration check: 0:00:00 ago on Thu 14 Sep 2017 03:16:26 PM IST.
Error: 
 Problem 1: package grub2-1:2.02-0.40.fc26.x86_64 requires grub2-tools = 1:2.02-0.40.fc26, but none of the providers can be installed
  - grub2-tools-1:2.02-0.40.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package grub2-1:2.02-0.40.fc26.x86_64
 Problem 2: package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - problem with installed package abrt-java-connector-1.1.0-11.fc26.x86_64
  - rpm-libs-4.13.0.1-7.fc26.x86_64 does not belong to a distupgrade repository
  - abrt-java-connector-1.1.0-11.fc26.x86_64 does not belong to a distupgrade repository


Expected results:
dnf should download f27 packages required

Additional info:
Comment 1 Chris Murphy 2017-11-11 14:34:42 EST
I was able to get around this by first doing:
dnf remove grub2 grub2-efi-modules

Possible dups:
https://bugzilla.redhat.com/show_bug.cgi?id=1502312
https://bugzilla.redhat.com/show_bug.cgi?id=1506704
Comment 2 Chris Murphy 2017-11-14 20:57:19 EST
The consistent complain among all the dups I've found so far is with grub2-tools. 

grub2-tools-1:2.02-0.40.fc26.x86_64 does not belong to a distupgrade repository

--debug-solver unfortunately does not work with system-upgrade plug-in, I get an empty debugdata directory when using it against this error.
Comment 3 Chris Murphy 2017-11-14 20:57:43 EST
*** Bug 1502312 has been marked as a duplicate of this bug. ***
Comment 4 Chris Murphy 2017-11-14 20:57:53 EST
*** Bug 1506704 has been marked as a duplicate of this bug. ***
Comment 5 Rajeesh 2017-11-15 13:11:39 EST
(In reply to Chris Murphy from comment #1)
> I was able to get around this by first doing:
> dnf remove grub2 grub2-efi-modules
> 
I tried removing grub2 and grub2-efi-modules, but it completely broke the system -- on reboot, only the MOK manager comes up and there is no way to proceed booting. Had to resort to rescue from a livecd and reinstall grub2-tools and shim.
Comment 6 Chris Murphy 2017-11-15 14:14:20 EST
(In reply to Rajeesh from comment #5)
> I tried removing grub2 and grub2-efi-modules, but it completely broke the
> system -- on reboot, only the MOK manager comes up and there is no way to
> proceed booting. Had to resort to rescue from a livecd and reinstall
> grub2-tools and shim.

Yeah that just tells me it's a non-standard grub installation. I speculate that grub2-efi-modules was manually installed; and subsequently grub2-install was used which obliterated the Fedora grubx64.efi, resulting in a grub that needs the external modules present to work. So when uninstalling grub2-efi-modules, the bootloader broke.

Maybe a one size fits all work around is removing the items in the error message (in my case grub2 and grub2-efi-modules) and then reinstalling grub2-efi and shim, and running grub2-mkconfig pointed to /boot/efi/EFI/fedora/grub.cfg to make sure it's a standard bootloader installation first. Then do dnf system-upgraded download.
Comment 7 Robert Bottomley 2017-11-15 17:26:55 EST
I was having this issue on a laptop that I tried to upgrade. Doing:

 dnf remove grub2 grub2-efi

worked for me. I was then able to upgrade to Fedora 27 with no further problems.
Comment 8 Adam Williamson 2017-11-15 17:44:56 EST
The initial report here in fact reports *two* bugs. The first is the same as 1506704 : the reporter has grub2-efi-modules installed, in F27 that package no longer exists, but is not properly obsoleted/provided.

The other is a different problem:

 Problem 2: package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - problem with installed package abrt-java-connector-1.1.0-11.fc26.x86_64
  - rpm-libs-4.13.0.1-7.fc26.x86_64 does not belong to a distupgrade repository
  - abrt-java-connector-1.1.0-11.fc26.x86_64 does not belong to a distupgrade repository

That's nothing to do with grub2. It's likely a similar kind of problem: the obvious guess is that abrt-java-connector was removed without being obsoleted/provided by anything else. I will check into that one separately.

I've made 1506704 the primary bug for 'nothing obsoletes grub2-efi-modules', since that report *only* talks about that problem. We can either make this report cover the abrt-java-connector issue, or close this as a dupe of #1506704 and file a new report for abrt-java-connector.
Comment 9 Adam Williamson 2017-11-15 17:45:41 EST
BTW, I *strongly* recommend that nobody remove the grub2 or grub2-efi packages in an attempt to work around issues like this. It is very likely to cause problems in some cases. Please wait for pjones to address these problems properly.
Comment 10 Jose Gaetan Pierre 2017-11-20 03:03:15 EST
on my laptop ( DELL INSPIRON ) have just tried:
sudo dnf system-upgrade download --refresh --releasever=27

with this result:
Error: 
 Problem: package grub2-efi-1:2.02-0.40.fc26.i686 requires grub2-tools = 1:2.02-0.40.fc26, but none of the providers can be installed
  - grub2-tools-1:2.02-0.40.fc26.i686 does not belong to a distupgrade repository
  - problem with installed package grub2-efi-1:2.02-0.40.fc26.i686

frustrating. Am following advice not to remove grub2-efi.

Waiting for a fix :-)
Comment 11 Daniel Boiko 2017-11-22 07:47:47 EST
In my case I have:
Error: 
 Problem: package grub2-efi-modules-1:2.02-0.40.fc26.x86_64 requires grub2-tools = 1:2.02-0.40.fc26, but none of the providers can be installed
  - grub2-tools-1:2.02-0.40.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package grub2-efi-modules-1:2.02-0.40.fc26.x86_64
Comment 12 Adam Williamson 2017-11-22 16:57:18 EST
Daniel: that is #1506704.
Comment 13 Steve Elliott 2017-11-22 18:27:33 EST
(In reply to Adam Williamson from comment #8)
> The initial report here in fact reports *two* bugs.
....
>  Problem 2: package abrt-java-connector-1.1.0-8.fc24.x86_64 requires
....
> 
> That's nothing to do with grub2. It's likely a similar kind of problem: the
> obvious guess is that abrt-java-connector was removed without being
> obsoleted/provided by anything else. I will check into that one separately.
...

Adam,
I also have a 2nd problem reported:

--------------
 Problem 2: problem with installed package guvcview-2.0.4-6.fc26.x86_64
  - package guvcview-2.0.4-6.fc27.x86_64 requires libgsl.so.19()(64bit), but none of the providers can be installed
  - guvcview-2.0.4-6.fc26.x86_64 does not belong to a distupgrade repository
  - gsl-2.3-1.fc26.x86_64 does not belong to a distupgrade repository
--------------

Could you please add this to the mix.

Many thanks
Steve Elliott
Comment 14 Adam Williamson 2017-11-22 18:55:02 EST
No. This isn't a "mix". It's a bug report. It's not a dumping ground for every error with vaguely similar text.

If it doesn't involve the same packages *IT IS NOT THE SAME ERROR*. Please file it separately. I do not have a "mix" to add it to. You need to file it against the package that actually has the problem, so the maintainer of that package can fix it.

Thanks.
Comment 15 Steve Elliott 2017-11-22 20:03:46 EST
(In reply to Steve Elliott from comment #13)

>  Problem 2: problem with installed package guvcview-2.0.4-6.fc26.x86_64

I have reported this at:

https://sourceforge.net/p/guvcview/tickets/41/
Comment 16 Adam Williamson 2017-11-22 20:10:55 EST
Sorry, you need to report it against the *package* guvcview, it's not an upstream code problem, but a packaging problem.

However, it looks like guvcview is not a Fedora package. You have it from a third-party repository, probably RPM Fusion. Fusion is a separate project from Fedora, we cannot handle Fusion bugs in this Bugzilla. The correct place to file your problem would be wherever RPM Fusion handles bugs, I think https://bugzilla.rpmfusion.org/ . Thanks.
Comment 17 Steve Elliott 2017-11-22 22:38:36 EST
(In reply to Steve Elliott from comment #15)
> (In reply to Steve Elliott from comment #13)
> 
> >  Problem 2: problem with installed package guvcview-2.0.4-6.fc26.x86_64
> 
> I have reported this at:
> 
> https://sourceforge.net/p/guvcview/tickets/41/

Now filed at:

https://bugzilla.rpmfusion.org/show_bug.cgi?id=4717
Comment 18 John Soros 2017-12-01 08:03:26 EST
I have an issue that is probably related to this. After the upgrade I tried to clean up the system, but it wants to remove grub:
# dnf autoremove
...
Removing:
...
 grub2-efi-x64                                                 x86_64                                 1:2.02-19.fc27                                                @updates                                 3.4 M
 grub2-pc                                                      x86_64                                 1:2.02-19.fc27                                                @updates                                   0  
 grub2-pc-modules                                              noarch                                 1:2.02-19.fc27                                                @updates                                 2.2 M
 grub2-tools                                                   x86_64                                 1:2.02-19.fc27                                                @updates                                 8.3 M
 grub2-tools-efi                                               x86_64                                 1:2.02-19.fc27                                                @updates                                 1.8 M
 grub2-tools-extra                                             x86_64                                 1:2.02-19.fc27                                                @updates                                 5.8 M
...
os-prober                                                     x86_64                                 1.74-3.fc27                                                   @fedora                                  103 k
Comment 19 Matt Hirsch 2017-12-06 00:36:06 EST
A couple comments --

I'm certain I never installed grub2-tools or grub2-efi-modules manually on my systems. I have multiple that have hit this issue. Is it possible that this package would have been installed in the process of updating through older versions of fedora? I noticed that systems that were fresh installs starting with F25 did not hit this issue, but systems that were first installed with older versions of Fedora do have this issue. I'm not sure which versions of Fedora were first installed on my two affected systems, only that it was less recent than F25.

I thought I'd suggest another workaround. Instead of using system-upgrade, which requires a reboot, I was able to upgrade the running system using dnf by first uninstalling grub2-efi-modules, then following these instructions, (https://fedoraproject.org/wiki/Upgrading_Fedora_using_package_manager?rd=Upgrading_Fedora_using_yum), then reinstalling the fedora 27 version of grub2-efi-x64-modules before rebooting.
Comment 20 Adam Williamson 2017-12-07 14:27:45 EST
"Is it possible that this package would have been installed in the process of updating through older versions of fedora?"

It's possible, yeah, and it's a reasonable suspect. I haven't had the time to figure it out yet, though. Figuring it out would require going through the history of the package spec looking for times when grub2-efi-modules would've been installed as a replacement for some other package, or when grub2-efi had a dependency on it, or something like that.
Comment 21 sksbir 2017-12-31 11:07:53 EST
hi

Same problem : 
Problème: package grub2-efi-1:2.02-0.40.fc26.i686 requires grub2-tools = 1:2.02-0.40.fc26, but none of the providers can be installed
  - grub2-tools-1:2.02-0.40.fc26.i686 does not belong to a distupgrade repository

On EEEPC laptop which was only used for skype since Fedora 24.

Here is history of root, just in case because it shows all commands since begining :

1  cd /etc/repo.d
    2  cd /etc
    3  cd yum.repos.d/
    4  ll
    5  vi skype.repo
    6  yum install skype
    7  cat skype.repo 
    8  man dnf
    9  yum install skype --nogpgcheck
   10  dns uninstall skype
   11  dnf uninstall skype
   12  man dnf
   13  exit
   14  vi /etc/sudoers
   15  useradd
   16  adduser
   17  system-config-users
   18  dnf install system-config-users
   19  system-config-users
   20  exit
   21  dnf upgrade
   22  passwd
   23  dnf update
   24  shutdown -Fr
   25  dnf update
   26  df -h
   27  dnf autoremove
   28  exit
   29  vi /etc/X11/xorg.conf.d/99-synaptics-overrides.conf
   30  dnf update
   31  df
   32  df -h
   33  dnf --enablerepo=updates-testing install mediawriter
   34  reboot
   35  dnf --enablerepo=updates-testing install mediawriter
   36  dnf install mediawriter
   37  dnf search filezilla
   38  dnf install filezilla
   39  dnf upate
   40  dnf update
   41  exit
   42  dnf upgrade --refresh
   43  dnf install dnf-plugin-system-upgrade
   44  dnf system-upgrade download --releasever=24
   45  dnf system-upgrade reboot
   46  dnf remove skype
   47  dnf system-upgrade reboot
   48  dnf system-upgrade download --releasever=24
   49  dnf system-upgrade reboot
   50  systemctl start sshd.service
   51  systemctl enable sshd.service
   52  ate
   53  date
   54  timedatectl list-timezones
   55  timedatectl list-timezones|grep -i leb
   56  timedatectl list-timezones|grep -i beyr
   57  timedatectl list-timezones
   58  timedatectl list-timezones|grep -i beir
   59  timedatectl set-timezone Asia/Beirut
   60  date
   61  dnf repolist all
   62  dnf config-manager --set-disable skype
   63  dnf repolist all
   64  cd /home/xxxx
   65  c Téléchargements/
   66  cd Téléchargements/
   67  ll
   68  scp 192.168.0.106:`pwd`/* .
   69  ll
   70  chown xxxx:xxxxteamviewer_11.0.67687.i686.rpm 
   71  ll
   72  rm Fedora-LXDE-Live-i386-24-1.2.iso 
   73  ll
   74  rm *rent
   75  ll
   76  rm *part
   77  ll Fedora-LXDE-Live-i386-24
   78  ll
   79  dnf install skype-4.3.0.37-fedora.i586.rpm 
   80  dnf install teamviewer_11.0.67687.i686.rpm 
   81  dnf remove midori
   82  id
   83  dnf install keepass
   84  dnf dist-upgrade
   85  dnf distupgrade
   86  dnf upgrae
   87  dnf upgrade
   88  exit
   89  dnf upayr
   90  dnf update
   91  dnf install dnf-plugin-system-upgrade
   92  dnf system-upgrade download --refresh --releasever=25
   93  dnf system-upgrade reboot
   94  dnf upgrade --refresh
   95  dnf system-upgrade download --refresh --releasever=26
   96  dnf system-upgrade reboot
   97  cd /etc/X11
   98  cd xorg.conf.d/
   99  ll
  100  vi 99-synaptics-overrides.conf 
  101  dnf refresh upgrade
  102  dnf upgrade --refresh
  103  reboot
  104  dnf upgrade
  105  dnf upgrade --refresh
  106  dnf system-upgrade download --refresh --releasever=27
  107  dnf autoremove
  108  reboot
  109  vi 99-synaptics-overrides.conf 
  110  cd /etc/X11
  111  vi 99-synaptics-overrides.conf 
  112  dnf system-upgrade download --refresh --releasever=27
  113  dnf install dnf-plugin-system-upgrade
  114  dnf system-upgrade download --refresh --releasever=27
Comment 22 Adam Williamson 2018-01-03 18:51:44 EST
sksbir: that is not in fact the same problem. That is https://bugzilla.redhat.com/show_bug.cgi?id=1502312 .

Note You need to log in before you can comment on or make changes to this bug.