Bug 149164 - problems with init script
problems with init script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openswan (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-19 14:18 EST by Ulrich Drepper
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 09:52:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2005-02-19 14:18:05 EST
Description of problem:
openswan's init script has two problems:

/etc/init.d/ipsec: line 50: [: too many arguments
/usr/sbin/ipsec: unknown IPsec command `_confread' (`ipsec --help' for list)

The first problem is due to insufficient quoting.  The second is due to lib ->
lib64.


Version-Release number of selected component (if applicable):
openswan-2.3.0-3.x86_64

How reproducible:
always (at least the second one)

Steps to Reproduce:
1.run script
2.
3.
  
Actual results:
see above

Expected results:
no messages

Additional info:

The first problem can be corrected with

-[ `tty` != '/dev/console' ] && TTY=1;
+[ "`tty`" != '/dev/console' ] && TTY=1;

Or maybe even better, start using $( ) instead of backticks.


For biarch 64-bit platforms this is needed:

-IPSEC_LIBDIR="${IPSEC_LIBDIR-/usr/lib/ipsec}"
+IPSEC_LIBDIR="${IPSEC_LIBDIR-/usr/lib64/ipsec}"

I guess the best way to deal with this is to rewrite the file during
compilation.  I haven't looked at the package, though.

Note You need to log in before you can comment on or make changes to this bug.