Bug 1491687 - vpnc not available in GNOME NetworkManager on RHEL Desktop & CentOS (Missing files in /usr/lib64/NetworkManager)
Summary: vpnc not available in GNOME NetworkManager on RHEL Desktop & CentOS (Missing ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: NetworkManager-vpnc
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Huzaifa S. Sidhpurwala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1509539 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-14 12:15 UTC by Franck WIATROWSKI
Modified: 2017-11-16 15:47 UTC (History)
10 users (show)

Fixed In Version: NetworkManager-vpnc-1.2.4-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-16 15:47:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Franck WIATROWSKI 2017-09-14 12:15:57 UTC
Description of problem:
After install of NetworkManager-vpnc & NetworkManager-vpnc-gnome, vpnc VPN not available in Gnome NetworkManager. 
After Searching in paths, i notice that some files missing in  /usr/lib64/NetworkManager. I use files from a fedora 26 installation and vpnc available again in GNOME NetworkManager.

Version-Release number of selected component (if applicable):
NetworkManager-vpnc-gnome-1.0.8-1.el7.x86_64

How reproducible:

Steps to Reproduce:
1. install NetworkManager-vpnc-gnome-1.0.8-1.el7.x86_64
2. try to create a vpnc VPN in gnome NetworkManager
3. vpnc not Available

Actual results:
no vpnc

Expected results:
vpnc available

Additional info:
tested on RHEL Desktop 7.4 & CentOS 7.4

Comment 1 Klaus Wenninger 2017-09-15 09:58:32 UTC
In the course of getting vpnc-plugin fixed with EPEL it probably makes sense to as well update the vpnc-package itself.
From what I've seen svn469 is needed as minimum to be able to setup a tunnel to a FritzBox - which I guess is one of the common scenarios.
Currently available with EPEL 7 is svn457.
I've tested that scenario to be working with svn550.

Comment 2 Fedora Update System 2017-09-18 14:28:01 UTC
NetworkManager-vpnc-1.2.4-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c6967768aa

Comment 3 Thomas Haller 2017-09-18 14:33:13 UTC
(In reply to Klaus Wenninger from comment #1)
> In the course of getting vpnc-plugin fixed with EPEL it probably makes sense
> to as well update the vpnc-package itself.
> From what I've seen svn469 is needed as minimum to be able to setup a tunnel
> to a FritzBox - which I guess is one of the common scenarios.
> Currently available with EPEL 7 is svn457.
> I've tested that scenario to be working with svn550.

"vpnc" and "NetworkManager-vpnc" are two different package, albeit related.
Please open a separate bug for this request. Thank you.

Comment 4 Klaus Wenninger 2017-09-18 16:13:09 UTC
(In reply to Thomas Haller from comment #3)
> (In reply to Klaus Wenninger from comment #1)
> > In the course of getting vpnc-plugin fixed with EPEL it probably makes sense
> > to as well update the vpnc-package itself.
> > From what I've seen svn469 is needed as minimum to be able to setup a tunnel
> > to a FritzBox - which I guess is one of the common scenarios.
> > Currently available with EPEL 7 is svn457.
> > I've tested that scenario to be working with svn550.
> 
> "vpnc" and "NetworkManager-vpnc" are two different package, albeit related.
> Please open a separate bug for this request. Thank you.

added as bz1492801

Comment 5 Fedora Update System 2017-09-19 17:20:02 UTC
NetworkManager-vpnc-1.2.4-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c6967768aa

Comment 6 Thomas Haller 2017-11-04 17:19:41 UTC
*** Bug 1509539 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2017-11-16 15:47:59 UTC
NetworkManager-vpnc-1.2.4-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.