Bug 1491708 - wpa_supplicant// wireless connection stops working after second rekeying
Summary: wpa_supplicant// wireless connection stops working after second rekeying
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-14 12:51 UTC by Paul Lazare
Modified: 2017-11-01 16:38 UTC (History)
16 users (show)

Fixed In Version: linux-firmware-20170828-77.gitb78acc9.fc26 linux-firmware-20170828-77.gitb78acc9.fc27 linux-firmware-20170828-77.gitb78acc9.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-22 18:52:12 UTC
Type: Bug


Attachments (Terms of Use)
journalctl capture (258.11 KB, text/x-vhdl)
2017-09-14 12:51 UTC, Paul Lazare
no flags Details

Description Paul Lazare 2017-09-14 12:51:48 UTC
Created attachment 1325990 [details]
journalctl capture

Description of problem:
I use Fedora 26 on my Acer Swift 5 and I have had issues with wifi connection for last two days. Probably it started after update, but I am not sure.

The network stops working every 20 minutes.
Looking through the logs I have narrowed it down to the following message:
wpa_supplicant[8943]: wlp1s0: WPA: Group rekeying completed with 64:70:02:67:66:24 [GTK=CCMP]

If I restart NM or wpa_supplicant, everything gets back to normal, then I see rekeying message first time and connection is fine, then after the second rekeying message connection stops.

I enclose capture of 
$ journalctl -u NetworkManager -u wpa_supplicant.service --since "last 20 minutes"

Version-Release number of selected component (if applicable):
wpa_supplicant-2.6-8.fc26.x86_64
NetworkManager-1.8.2-1.fc26.x86_64

How reproducible:
always

Steps to Reproduce:
1. Restart wpa_supplicant
2. Wait for second rekeying to happen.
3.

Actual results:


Expected results:


Additional info:

Adapter/driver info:

$ lspci -vv -s 01:00.0
01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
        Subsystem: Foxconn International, Inc. Device e09d
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 279
        Region 0: Memory at b1000000 (64-bit, non-prefetchable) [size=2M]
        Capabilities: <access denied>
        Kernel driver in use: ath10k_pci
        Kernel modules: ath10k_pci

$ modinfo ath10k_pci
filename:       /lib/modules/4.12.11-300.fc26.x86_64/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko.xz
firmware:       ath10k/QCA9377/hw1.0/board.bin
firmware:       ath10k/QCA9377/hw1.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/board-2.bin
firmware:       ath10k/QCA6174/hw3.0/board.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-6.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-4.bin
firmware:       ath10k/QCA6174/hw2.1/board-2.bin
firmware:       ath10k/QCA6174/hw2.1/board.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-5.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-4.bin
firmware:       ath10k/QCA9887/hw1.0/board-2.bin
firmware:       ath10k/QCA9887/hw1.0/board.bin
firmware:       ath10k/QCA9887/hw1.0/firmware-5.bin
firmware:       ath10k/QCA988X/hw2.0/board-2.bin
firmware:       ath10k/QCA988X/hw2.0/board.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-5.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-4.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-3.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-2.bin
license:        Dual BSD/GPL
description:    Driver support for Qualcomm Atheros 802.11ac WLAN PCIe/AHB devices
author:         Qualcomm Atheros
alias:          pci:v0000168Cd00000050sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000042sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000046sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000056sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000040sv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000003Esv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000041sv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000003Csv*sd*bc*sc*i*
depends:        ath10k_core
intree:         Y
vermagic:       4.12.11-300.fc26.x86_64 SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           irq_mode:0: auto, 1: legacy, 2: msi (default: 0) (uint)
parm:           reset_mode:0: auto, 1: warm only (default: 0) (uint)

Comment 1 Garrett LeSage 2017-09-15 15:26:44 UTC
I'm having the same exact problem on my Dell XPS 13 (9360 Kaby Lake) with a Qualcomm Atheros QCA6174 chip after upgrading to linux-firmware-20170828-76.gitb78acc9.

It's a show-stopping bug for the XPS 13 laptops, which are quite popular to run Linux on these days.

Others are having the same issue with similar laptops too:
https://bodhi.fedoraproject.org/updates/linux-firmware-20170828-76.gitb78acc9.fc26


After recompiling 20170622-75.gita3a26af2.fc26.src.rpm, installing the old RPM, and rebooting, my WiFi connection is completely stable, as before, which confirms something broke quite a bit between releases.

Basically: The problem is in the new version of the QCA6174 support in the linux-firmware RPM.

Comment 2 Klaas Demter 2017-09-16 10:10:26 UTC
I can confirm Garretts findings. Downgrade of linux-firmware and it works stable again (same hardware as him).

Comment 3 Klaas Demter 2017-09-16 14:28:27 UTC
working (20170622-75.gita3a26af2.fc26)
[root@notebook klaas]# ethtool -i wlp58s0
driver: ath10k_pci
version: 4.12.12-300.fc26.x86_64
firmware-version: WLAN.RM.2.0-00180-QCARMSWPZ-1
expansion-rom-version: 
bus-info: 0000:3a:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no


Not working (linux-firmware-20170828-76.gitb78acc9.fc26.noarch)
[root@notebook klaas]# ethtool -i wlp58s0
driver: ath10k_pci
version: 4.12.12-300.fc26.x86_64
firmware-version: WLAN.RM.4.4-00022-QCARMSWPZ-2
expansion-rom-version: 
bus-info: 0000:3a:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no


For the fun of it I also tried the latest driver, it seems to work on first try
[root@notebook klaas]# ethtool -i wlp58s0
driver: ath10k_pci
version: 4.12.12-300.fc26.x86_64
firmware-version: WLAN.RM.4.4.1-00051-QCARMSWP-1
expansion-rom-version: 
bus-info: 0000:3a:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no

Comment 4 Klaas Demter 2017-09-18 17:23:25 UTC
Fix in https://marc.info/?l=linux-wireless&m=150574717626917

Comment 5 Josh Boyer 2017-09-18 20:26:19 UTC
I've done a scratch build with those patches included.  Can you test this build and let me know if it works for you?

https://koji.fedoraproject.org/koji/taskinfo?taskID=21959422

Comment 6 Fedora Update System 2017-09-20 13:25:32 UTC
linux-firmware-20170828-77.gitb78acc9.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ac7e52d53f

Comment 7 Fedora Update System 2017-09-20 13:26:12 UTC
linux-firmware-20170828-77.gitb78acc9.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-aac60d40ce

Comment 8 Fedora Update System 2017-09-20 13:26:35 UTC
linux-firmware-20170828-77.gitb78acc9.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d2803ce4f5

Comment 9 Fedora Update System 2017-09-20 15:22:07 UTC
linux-firmware-20170828-77.gitb78acc9.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-aac60d40ce

Comment 10 Fedora Update System 2017-09-20 20:49:14 UTC
linux-firmware-20170828-77.gitb78acc9.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d2803ce4f5

Comment 11 Fedora Update System 2017-09-20 23:51:01 UTC
linux-firmware-20170828-77.gitb78acc9.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ac7e52d53f

Comment 12 Paul Lazare 2017-09-21 09:53:54 UTC
(In reply to Josh Boyer from comment #5)
> I've done a scratch build with those patches included.  Can you test this
> build and let me know if it works for you?
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=21959422

linux-firmware-20170828-77.gitb78acc9.fc26 seems to be working fine. Thank you!

Comment 13 Paul Lazare 2017-09-21 09:55:20 UTC
(In reply to Garrett LeSage from comment #1)
> I'm having the same exact problem on my Dell XPS 13 (9360 Kaby Lake) with a
> Qualcomm Atheros QCA6174 chip after upgrading to
> linux-firmware-20170828-76.gitb78acc9.
> 
> It's a show-stopping bug for the XPS 13 laptops, which are quite popular to
> run Linux on these days.
> 
> Others are having the same issue with similar laptops too:
> https://bodhi.fedoraproject.org/updates/linux-firmware-20170828-76.
> gitb78acc9.fc26
> 
> 
> After recompiling 20170622-75.gita3a26af2.fc26.src.rpm, installing the old
> RPM, and rebooting, my WiFi connection is completely stable, as before,
> which confirms something broke quite a bit between releases.
> 
> Basically: The problem is in the new version of the QCA6174 support in the
> linux-firmware RPM.

Garrett, thanks for downgrade suggestion, it worked for me too.

Comment 14 Fedora Update System 2017-09-22 18:52:12 UTC
linux-firmware-20170828-77.gitb78acc9.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-09-30 06:44:20 UTC
linux-firmware-20170828-77.gitb78acc9.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-11-01 16:38:08 UTC
linux-firmware-20170828-77.gitb78acc9.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.