Bug 149175 - Missing Build-Dependency on apmd
Missing Build-Dependency on apmd
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-applets (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-19 21:19 EST by Andreas Thienemann
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 03:24:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2005-02-19 21:19:18 EST
There seems to be a bug in the Dependency defintion for the
gnome-applets-2.8.0-5.1 package.

Even though the apmd_archs is defined in the specfile

# apmd is built on %{ix86} and ppc
%define apmd_archs %{ix86} ppc

and the Build-Dependency on apmd is defined in the spec

%ifarch ${apmd_archs}
BuildRequires:  apmd >= %{apmd_version}
%endif

rebuilding without apmd does result in the following message:

Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.20091
+ umask 022
+ cd /usr/src/redhat/BUILD
+ test -e /usr/lib/libapm.a
+ echo 'You must have apmd installed'
You must have apmd installed
+ exit 1
error: Bad exit status from /var/tmp/rpm-tmp.20091 (%prep)


This should actually not happen as rpm should be able to notice that no apmd
package is available and complain right after the dependency check.

Substituting ${apmd_archs} with %{apmd_archs} in the %ifarch statement seems to
fix this problem.
Comment 1 Mark McLoughlin 2005-02-21 03:24:26 EST
Nicely spotted, many thanks.

This was already fixed in the FC-4 development branch, but I've put
the fix into the RHEL-4 and FC-3 branches too now. However, I didn't
release an update with just this fix, but it will be in the next
update that gets releasted.

Note You need to log in before you can comment on or make changes to this bug.