Bug 1491751 - Fedora-Server-dvd-ppc64-27-20170913.n.0.iso failed to install
Summary: Fedora-Server-dvd-ppc64-27-20170913.n.0.iso failed to install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-09-14 14:52 UTC by Menanteau Guy
Modified: 2017-10-11 07:59 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-10-05 14:34:37 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2017-09-14 14:52:42 UTC
I am not able to install Fedora-Server-dvd-ppc64-27-20170913.n.0.iso on VM ppc64.
Dracut failed with following messages

dracut-initqueue:anaconda: found /run/install/repo//images/install.img
dracut-initqueue:mount: /tmp/unpack_fs.0: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error.
dracut-initqueue:/lib/img-lib.sh: line 54: rmdir: command not found
dracut-initqueue:Warning: can't unpack filesystem image!
dracut-initqueue:/lib/anaconda-lib.sh: line 144: cd: /tmp/product.img.743: No such file or directory
dracut-initqueue:cp: cannot copy a directory, '.', into itself, '/updates/.'
dracut-initqueue: cp: error reading './proc/task/1/mem': Input/output error
dracut-initqueue: cp: error reading './proc/task/1/clear_refs': Invalid argument
...

Comment 1 Dan Horák 2017-09-14 15:25:42 UTC
There is similar problem in the Fedora OpenQA instance - https://openqa.stg.fedoraproject.org/tests/160500#step/_boot_to_anaconda/10

Adding more RAM to the VM could help.

Comment 2 Menanteau Guy 2017-09-15 07:37:21 UTC
I tested with more RAM on VM without any success.
I did not find what was wrong but actually the problem is not anymore in Fedora-Server-dvd-ppc64-27-20170914.n.0.iso so I close this bug.

Comment 3 Dan Horák 2017-09-15 07:48:34 UTC
also the sizes of install.img and kernel and initrd images are the same between the 0913 and 0914 composes

Comment 4 Menanteau Guy 2017-09-18 08:55:19 UTC
Problem is back on version of Fedora-Server-dvd-ppc64le-27-20170917.n.0.iso
https://openqa.stg.fedoraproject.org/tests/overview?distri=fedora&version=27&build=Fedora-27-20170917.n.0&groupid=3

Comment 5 Menanteau Guy 2017-09-18 09:41:40 UTC
Note that the problem is also present on ppc64le and on a baremetal installation too.

Comment 6 Sinny Kumari 2017-09-21 14:41:10 UTC
(In reply to Menanteau Guy from comment #5)
> Note that the problem is also present on ppc64le and on a baremetal
> installation too.

I tried with today's nightly compose from https://kojipkgs.fedoraproject.org/compose/branched/Fedora-27-20170921.n.0/compose/Server/ both Fedora-Server-dvd-ppc64le-27-20170921.n.0.iso and Fedora-Server-dvd-ppc64-27-20170921.n.0.iso . Both got installed and booted successfully. Can you please try and let us know if you still see the issue?

Comment 7 Menanteau Guy 2017-09-21 14:59:29 UTC
(In reply to Sinny Kumari from comment #6)
> (In reply to Menanteau Guy from comment #5)
> > Note that the problem is also present on ppc64le and on a baremetal
> > installation too.
> 
> I tried with today's nightly compose from
> https://kojipkgs.fedoraproject.org/compose/branched/Fedora-27-20170921.n.0/
> compose/Server/ both Fedora-Server-dvd-ppc64le-27-20170921.n.0.iso and
> Fedora-Server-dvd-ppc64-27-20170921.n.0.iso . Both got installed and booted
> successfully. Can you please try and let us know if you still see the issue?

Problem was present on composes of 27-2017013 and 27-20170917. I did not find what trigger it on some composes and not on others.
Currently the issue is not there. We can close the problem as I already did but I am afraid it will come back later.

Comment 8 Menanteau Guy 2017-10-05 14:34:37 UTC
I did not get the problem again still the 27-20170917 version so I close this bug. I will reopen it if the problem come back.

Comment 9 Harald Hoyer 2017-10-11 07:59:02 UTC
this was an anaconda problem (dracut part of anaconda)


Note You need to log in before you can comment on or make changes to this bug.