Bug 149185 - X resolution off limits (was the same with FC3 stable)
X resolution off limits (was the same with FC3 stable)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-20 07:58 EST by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 02:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2005-02-20 07:58:01 EST
Description of problem: 
 
This problem was with FC3 stable, at still exists with development 
dated 20Feb2005. 
 
System: 
Monitor: Acer AL922 (19" LCD screen with DVI) 
Graphic card : ATI radeaon 9800XT 
CPU: P4 3.2 
 
1. At install: 
Screen resolution is off limits, screen is blank (fixed when starting 
install with "linux resolution=1280x1024") 
 
2. After install (1st boot up) 
X resolution is off limits. I have to edit xorg.conf manually (I add 
Option "DCC" in monitor section, and resolutions 1280x1024 and 
1024x768 in screens") 
 
The default vert and horiz refresh rates are completely wrong for 
this monitor (I replace everything with Option "DCC"). 
 
Display on the monitor is one the basic features of the system, it is 
not understandable that it does not work on such basic hardware (19" 
LCD screen). 
Ubuntu Linux gets this right. Since this problem was in FC3 and still 
exists today in development, I suggest you have a look at how ubuntu 
are doing it.  
 
Thanks and regards. 
 
Version-Release number of selected component (if applicable): 
 
Fedora development dated 20Feb2005 (rsynced and burned DVD). 
Problem was the same with FC3 stable. 
 
How reproducible: 
 
Install fedora... reproductible everytime. 
 
Steps to Reproduce: 
1. Install Fedora (screen is balank -> offlimits) 
2. After install is off limits again (blank screen). 
3. 
   
Actual results: 
 
Screen is blank (vert and horiz refresh rates off limits) 
 
Expected results: 
 
Screen resolution should be detected correctly (why don't you use 
DCC ?) 
 
Additional info:
Comment 1 JW 2005-02-20 08:02:33 EST
For your information, Ubuntu Linux only puts Option "DCC" in the 
monitor section (they don't put vert/horiz refresh rates). And it 
works fine. 
Comment 2 Mike A. Harris 2005-03-07 12:45:41 EST
Forcing Option "DDC" in the X server config file is not an option
for default installation, because DDC probing is not 100% reliable
on all systems.  DDC can be non-operative due to KVM switches that
do not pass the DDC signal through, or due to CRT or DFP displays
that do not support DDC at all, or which have invalid or incorrect
DDC information.

We already default to DDC probing the monitor, and then configuring
the X server config to use the information returned by the DDC probe
if the probe is successful.  If the probe fails, or is otherwise
non-useable, then DDC simply can not be used, and the user must
pick their monitor from the list of known monitors, if their monitor
is known, or choose a generic type if not.

In order for us to investigate the problem you are encountering, we
need you to perform the following steps:

1) Backup your existing working X config file, in case you need
   it again later.

2) Switch to runlevel 3 (init 3)

3) Run "system-config-display --reconfig" to regenerate a brand
   new configuration with our tool.

4) Invoke the X server with "startx"

If the problem you have previously experienced still occurs, then
attach the resulting X server config file and log file to the bug
report as individual uncompressed file attachments using the link
below.

Additionally, if DDC probing does not work in the config tool,
you will need to pick your monitor manually from the list.  If your
monitor is not present on the list, we can add it to future updates
of the monitor database if you attach the Microsoft .INF file for
your display (which is obtainable from the manufacturer's website).


There
Comment 3 Mike A. Harris 2005-03-07 12:47:03 EST
oops, extraneous "there" above... cut and paste error...


Setting bug status to "NEEDINFO", awaiting testing results
and file attachments requested in previous comment.
Comment 4 Mike A. Harris 2005-04-15 11:22:13 EDT
ping
Comment 5 Mike A. Harris 2005-08-30 02:44:32 EDT
This bug has been idle for 6 months with no response to developer
inquiries.  Closing bug CANTFIX due to lack of information/response.

If this is still a problem in Fedora Core 4, please attach the
requested information and reopen the bug report.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.