Bug 1491910 - tomboy dependency issue
Summary: tomboy dependency issue
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tomboy
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-15 03:02 UTC by Mustafa Mahudhawala
Modified: 2017-09-28 23:55 UTC (History)
9 users (show)

Fixed In Version: tomboy-1.15.9-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-28 23:55:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Mustafa Mahudhawala 2017-09-15 03:02:44 UTC
Description of problem:

# rpm -q tomboy
tomboy-1.15.9-1.fc25.x86_64

# dnf update
Last metadata expiration check: 0:00:01 ago on Fri Sep 15 08:17:56 2017.
Dependencies resolved.
================================================================================
 Package               Arch         Version                 Repository     Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 dbus-sharp            x86_64       2:0.8.1-3.fc25          updates        91 k
 dbus-sharp-glib       x86_64       0.6.0-1.fc25            updates        15 k

Transaction Summary
================================================================================
Skip  2 Packages

# rpm -qp --provides dbus-sharp-0.8.1-3.fc25.x86_64.rpm
dbus-sharp = 2:0.8.1-3.fc25
dbus-sharp(x86-64) = 2:0.8.1-3.fc25
mono(dbus-sharp) = 2.0.0.0


# rpm -qp --provides dbus-sharp-glib-0.6.0-1.fc25.x86_64.rpm
dbus-sharp-glib = 0.6.0-1.fc25
dbus-sharp-glib(x86-64) = 0.6.0-1.fc25
mono(dbus-sharp-glib) = 2.0.0.0

# rpm -q --requires tomboy | grep mono\(dbus
mono(dbus-sharp) = 1.0.0.0
mono(dbus-sharp-glib) = 1.0.0.0

Updating dbus requires to remove tomboy due to dependency issue.

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
dnf update on f25

Actual results:

update fails for dbus.


Expected results:
update succeeds.


Additional info:
Need updated package for tomboy that is build with following dependency ..
mono(dbus-sharp) = 2.0.0.0
mono(dbus-sharp-glib) = 2.0.0.0

Comment 1 Fedora Update System 2017-09-19 18:32:33 UTC
tomboy-1.15.9-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-059c473dbd

Comment 2 Fedora Update System 2017-09-20 01:22:22 UTC
tomboy-1.15.9-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-059c473dbd

Comment 4 Fedora Update System 2017-09-28 23:55:27 UTC
tomboy-1.15.9-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.