Bug 1491957 - system not bootable - can not switch root - /usr/lib/os-release.d missing
Summary: system not bootable - can not switch root - /usr/lib/os-release.d missing
Status: CLOSED DUPLICATE of bug 1492208
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-release
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: pre-dev-freeze
: 7.5
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: 1469559
TreeView+ depends on / blocked
 
Reported: 2017-09-15 06:52 UTC by Marian Csontos
Modified: 2018-03-16 00:32 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-09-29 08:56:33 UTC


Attachments (Terms of Use)

Description Marian Csontos 2017-09-15 06:52:51 UTC
Description of problem:
After updating 7.4 machine system is not bootable - can not switch root - /usr/lib/os-release.d missing.
There is only os.release.d. See the dot instead of dash? I have not spotted it.

Version-Release number of selected component (if applicable):
redhat-release-7.5-0.4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install 7.4
2. update to 7.5
3. reboot
4. boom

/etc/os-release -> ../usr/lib/os-release
/usr/lib/os-release -> ./os.release.d/os-release-rhel

There is no /usr/lib/os-release.d, only os.release.d

Actual results:
system not bootable

Expected results:
system should boot

Additional info:
When reinstalling redhat-release I got followin warning:

  Installing : redhat-release-7.5-0.4.el7.x86_64                                                    1/1 
/var/tmp/rpm-tmp.PPdfQr: line 11: syntax error: unexpected end of file
warning: %posttrans(redhat-release-7.5-0.4.el7.x86_64) scriptlet failed, exit status 2
Non-fatal POSTTRANS scriptlet failure in rpm package redhat-release-7.5-0.4.el7.x86_64
  Verifying  : redhat-release-7.5-0.4.el7.x86_64                                                    1/1 

Installed:
  redhat-release.x86_64 0:7.5-0.4.el7                                                                   

Complete!
[root@r-bot-rhel74 lib]# ls -ld os-release* os.release.d os.release.d/*
lrwxrwxrwx 1 root root   30 Sep 15 08:47 os-release -> ./os-release.d/os-release-rhel
drwxr-xr-x 2 root root 4096 Sep 15 08:47 os.release.d
-rw-r--r-- 1 root root  495 Sep 13 10:57 os.release.d/os-release-rhel
-rw-r--r-- 1 root root  603 Sep 13 10:57 os.release.d/os-release-server

Comment 2 Lubos Kocman 2017-09-18 10:08:49 UTC
Ah thanks, most likely happened as part of merging redhat-release package into one.

Lubos

Comment 6 Lubos Kocman 2017-09-29 08:56:33 UTC

*** This bug has been marked as a duplicate of bug 1492208 ***


Note You need to log in before you can comment on or make changes to this bug.