Bug 149199 - Gamin and usb pendrive
Summary: Gamin and usb pendrive
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gamin   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-02-21 00:47 UTC by Giovanni Caruso
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 19:04:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch disables gam_server actions on banned paths. Works foe me. (826 bytes, patch)
2005-03-01 11:27 UTC, Anton Guda
no flags Details | Diff

Description Giovanni Caruso 2005-02-21 00:47:13 UTC
Gamin doesn't let me to umount my pen disk. It is necessary to kill it
&& umount the device

The version I tried is:
gamin-0.0.24-1.FC3


How reproducible:
Connect the pen disk and try to umount it

Actual results:
It's impossible to umount.

Expected results:
Umount 

Additional info:

None

Comment 1 David Zeuthen 2005-02-25 22:25:12 UTC
I can confirm this behavior with 0.0.24 - this makes it very difficult
to work with removable storage so I'm raising the severity to high.
Also fixing version to devel.

Comment 2 Anton Guda 2005-03-01 11:27:56 UTC
Created attachment 111527 [details]
This patch disables gam_server actions on banned paths. Works foe me.

It not a perfect solution -- in disables gam_server at all
for paths, markes as excludes (not using [di]notify, not pool).
It may be acceptable for removable drives

Comment 3 Daniel Veillard 2005-03-01 11:51:24 UTC
Patch is just wrong, it's a terrible regression, sorry I really
can't use this. I'm still chasing the real problem.

Daniel

Comment 4 Daniel Veillard 2005-03-01 21:43:56 UTC
Fix should be in release 0.0.25 of gamin available at
  http://www.gnome.org/~veillard/gamin/sources/
It's pushed to rawhide 

Daniel

Comment 5 David Zeuthen 2005-06-07 15:13:09 UTC
It looks to me that gamin-0.1.0-1.1 breaks this yet again (jrb experienced this
yesterday and I've just reproduced this) so I'm reopening this bug. It's also
really bad that this is the version in FC4, it really needs to be fixed so I'm
changing the priority to high.

DV, can you confirm the problem on your end?

Comment 6 Daniel Veillard 2005-06-07 16:55:06 UTC
No. I don't have FC-4, but on RHEL-4 with the exact same version of gamin 
recompiled locally and nautilus-2.8.1-4, plugging my USB drive with pictures
it shows up on the desktop automatically, I can browse the images, and then
if I right click on the drive icon, select umount, it does umount, the window
and icons disapears and df shows the volume has been unmounted.
Either the paths where the device it has been mounted to have changed in FC-4
but /media/ is forbidden by default from being watched with dnotify. And this
kind of checks is part of gamin regression tests nowadays.
I doubt it's really gamin regression, something else changed. The mount point
I'm seeing here is  /media/UDISK_2_0, and lsof /media/UDISK_2_0 with
nautilus window open over the images on the drive shows no open descriptors
on it.
I think I can say I can't reproduce it at this point. Need more informations !

Daniel

Comment 7 David Zeuthen 2005-06-07 18:21:13 UTC
Just tried with downgrading to gamin-0.0.26-1 on Rawhide and that made things
work. So, this means the bug is indeed with gamin-0.1.0-1.1. Also, note the bug
here is that /usr/libexec/gnome-vfs-daemon doesn't catch the change in /etc/mtab
that occurs when gnome-volume-manager is invoking mount(1) (and mount(1) updates
the /etc/mtab file). Of course, there is the possibility that this is a bug with
gnome-vfs but since it works with gamin-0.0.26-1 (and fam before the gamin era)
I doubt it.

Please fix this soon, it's a very serious end-user bug.

Thanks,
David


Comment 9 Daniel Veillard 2005-06-07 18:38:26 UTC
So is that reproduced on Rawhide or FC-4 ?
I don't see how catching or not catching a change in /etc/mtab makes a
file system not unmountable, at least from a gamin perspective.
Can you explain *precisely* the sequence of event you did to reproduce 
the problem ? Could you also tell me the mount path used for the device
and the lsof output for that device ?

Daniel

Comment 10 David Zeuthen 2005-06-07 19:04:47 UTC
Sorry for hijacking this bug, my mistake, I've filed the issue detailed in
comment 7 in bug 159748. Closing this bug as RAWHIDE since the issue in this
report have been solved.


Note You need to log in before you can comment on or make changes to this bug.