Bug 1492 - lpr and mpage give different results when printing same file
Summary: lpr and mpage give different results when printing same file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr   
(Show other bugs)
Version: 5.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-12 13:48 UTC by tcarter
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-31 20:10:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tcarter 1999-03-12 13:48:56 UTC
I am creating primt files which I print with mpage.  I
noticed that the last line is not printed.  I then printed
the same file with lpr and noticed that the first line is
missing but the last line is there.  I would like to send
the print file to you (quite small) so you can see for
yourself.

In addition, mpage does not allow the automatic removal of
print files and lpr is missing many of the features of unix
lp (-c options) which limits the printing of files to
printers like lazerjets.

Comment 1 Jeff Johnson 1999-03-15 16:52:59 UTC
Could you please add the printfile to this bug using
e-mail so that we can reproduce the problem? Thanks

Comment 2 Preston Brown 1999-03-18 21:40:59 UTC
This sounds like the page is too long for the printer to handle to me.
What are you printing on?  does the Test Page print correctly from
inside printtool?

Comment 3 Jeff Johnson 1999-03-22 21:22:59 UTC
Just to get a header so's I can append the test file to the bug ...

------- Email Received From  Jeff Johnson <jbj@redhat.com> 03/22/99 16:28 -------

Comment 4 Jeff Johnson 1999-03-22 21:35:59 UTC
Here's the bug I mentioned...

Comment 5 Bill Nottingham 1999-03-22 22:16:59 UTC
I get identical results with the testfile here; the last
line is chopped off both with mpage & lpr, because there's no
newline at the end of the test file.

What specific options is lpr missing?

Comment 6 Preston Brown 1999-03-31 20:10:59 UTC
no real bug here.


Note You need to log in before you can comment on or make changes to this bug.