Bug 1492034 - Compute Node Scale out failing because of a NODE Stuck in Delete COMPLETE State
Summary: Compute Node Scale out failing because of a NODE Stuck in Delete COMPLETE State
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z6
: 10.0 (Newton)
Assignee: Rabi Mishra
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-15 10:04 UTC by Nikhil Shetty
Modified: 2020-12-14 10:04 UTC (History)
9 users (show)

Fixed In Version: openstack-heat-7.0.5-3.el7ost
Doc Type: Bug Fix
Doc Text:
Originally, it was not possible to update any resource (still existing in the template used for update) that was in `DELETE_COMPLETE`state. The problem has been fixed. As a result, all `DELETE_COMPLETE` resources are now replaced when the stack is updated.
Clone Of:
Environment:
Last Closed: 2017-11-15 13:44:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 504378 0 None None None 2017-09-20 06:56:57 UTC
Red Hat Product Errata RHBA-2017:3232 0 normal SHIPPED_LIVE openstack-heat bug fix advisory 2017-11-15 18:36:22 UTC

Description Nikhil Shetty 2017-09-15 10:04:06 UTC
Description of problem: Hello, This is to backport an Upstream Bug to Downstream, The bug is present in the URL
https://review.openstack.org/#/c/423355/


Version-Release number of selected component (if applicable): Red Hat Openstack Version 10


How reproducible: Trying to scale out, it is failing 
in UPDATE_FAILED STATE, when we do a Resource list for the Overcloud Resources, We get One Resource in DELETE_COMPLETE State

Actual results: Scale out fails


Expected results:Scale out should proceed and should be Successful


Additional info: Will provide Link for checking the SOSreport soon

Comment 3 Rabi Mishra 2017-09-20 07:00:40 UTC
Please also attach the relevant heat engine logs to know why/how the resource is in DELETE_COMPLETE in heat.

Comment 11 Ronnie Rasouli 2017-11-05 09:02:16 UTC
Scaled down and scale out successfully

Comment 13 errata-xmlrpc 2017-11-15 13:44:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3232


Note You need to log in before you can comment on or make changes to this bug.