Bug 1492078 - python3-tracer depends on python2 packages
Summary: python3-tracer depends on python2 packages
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tracer
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Kadlčík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-15 12:11 UTC by Lukas Slebodnik
Modified: 2018-05-09 16:13 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-30 16:36:16 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2017-09-15 12:11:14 UTC
Description of problem:
The latest update of python3-tracer pulled python2-argcomplete as a dependency
which is obviously wrong and cannot work. It might work just by a chance because python3-argcomplete can be installed as dependency of other package

Version-Release number of selected component (if applicable):
sh$ rpm -q python3-tracer
python3-tracer-0.6.13.1-1.fc27.noarch

How reproducible:
deterministic

Steps to Reproduce:
1. dnf install -y python3-tracer

Actual results:
[root@385f903c061b /]# dnf install -y python3-tracer
Fedora 27 - x86_64 - Test Updates                57 MB/s | 8.4 MB     00:00    
Fedora 27 - x86_64 - Updates                     12 kB/s | 373  B     00:00    
Fedora 27 - x86_64                               67 MB/s |  66 MB     00:00    
Last metadata expiration check: 0:00:00 ago on Fri Sep 15 12:02:08 2017.
Dependencies resolved.
================================================================================
 Package                 Arch    Version                 Repository        Size
================================================================================
Installing:
 python3-tracer          noarch  0.6.13.1-1.fc27         updates-testing  125 k
Installing dependencies:
 dbus-glib               x86_64  0.108-4.fc27            fedora           124 k
 libxslt                 x86_64  1.1.29-4.fc27           fedora           252 k
 python2                 x86_64  2.7.13-17.fc27          fedora            99 k
 python2-argcomplete     noarch  1.8.2-3.fc27            fedora            52 k
 python2-libs            x86_64  2.7.13-17.fc27          fedora           6.3 M
 python2-pip             noarch  9.0.1-11.fc27           fedora           1.8 M
 python2-setuptools      noarch  36.2.0-7.fc27           fedora           598 k
 python3-beautifulsoup4  noarch  4.6.0-2.fc27            fedora           178 k
 python3-cssselect       noarch  0.9.2-5.fc27            fedora            39 k
 python3-dbus            x86_64  1.2.4-8.fc27            fedora           121 k
 python3-html5lib        noarch  1:0.999999999-3.fc27    fedora           213 k
 python3-lxml            x86_64  3.8.0-1.fc27            fedora           1.0 M
 python3-psutil          x86_64  5.2.2-1.fc27            fedora           310 k
 python3-webencodings    noarch  0.5.1-3.fc27            fedora            25 k
 tracer-common           noarch  0.6.13.1-1.fc27         updates-testing   29 k

Transaction Summary
================================================================================
Install  16 Packages

Total download size: 11 M
Installed size: 44 M
Downloading Packages:

Expected results:
//only python3 dependencies are installed as it was in older release
[root@452b9c8576a8 /]# dnf install --disablerepo=updates-testing -y python3-tracer
Fedora 27 - x86_64 - Updates                     12 kB/s | 373  B     00:00    
Fedora 27 - x86_64                               76 MB/s |  66 MB     00:00    
Last metadata expiration check: 0:00:00 ago on Fri Sep 15 12:08:14 2017.
Dependencies resolved.
================================================================================
 Package                   Arch      Version                    Repository
                                                                           Size
================================================================================
Installing:
 python3-tracer            noarch    0.6.13.1-1.fc27            fedora    127 k
Installing dependencies:
 dbus-glib                 x86_64    0.108-4.fc27               fedora    124 k
 libxslt                   x86_64    1.1.29-4.fc27              fedora    252 k
 python3-argcomplete       noarch    1.8.2-3.fc27               fedora     55 k
 python3-beautifulsoup4    noarch    4.6.0-2.fc27               fedora    178 k
 python3-cssselect         noarch    0.9.2-5.fc27               fedora     39 k
 python3-dbus              x86_64    1.2.4-8.fc27               fedora    121 k
 python3-html5lib          noarch    1:0.999999999-3.fc27       fedora    213 k
 python3-lxml              x86_64    3.8.0-1.fc27               fedora    1.0 M
 python3-psutil            x86_64    5.2.2-1.fc27               fedora    310 k
 python3-webencodings      noarch    0.5.1-3.fc27               fedora     25 k
 tracer-common             noarch    0.6.13.1-1.fc27            fedora     29 k



Additional info:

sh$ rpm -q --requires python3-tracer
/usr/bin/python3
python(abi) = 3.6
python-argcomplete
python3-beautifulsoup4
python3-dbus
python3-lxml
python3-psutil
python3-setuptools
rpm-python3
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
tracer-common = 0.6.13.1-1.fc27

Comment 1 Lukas Slebodnik 2017-09-27 12:27:16 UTC
It would be good to get some feedback to this bug

Comment 2 Jakub Kadlčík 2017-09-28 22:48:21 UTC
Thank you Lukas for the feedback.

dnf repoquery --deplist python3-tracer

says this

package: python3-tracer-0.6.13.1-1.fc27.noarch
  dependency: /usr/bin/python3
   provider: python3-3.6.2-13.fc27.i686
   provider: python3-3.6.2-13.fc27.x86_64
  dependency: python(abi) = 3.6
   provider: python3-3.6.2-13.fc27.i686
   provider: python3-3.6.2-13.fc27.x86_64
  dependency: python-argcomplete
   provider: python2-argcomplete-1.8.2-3.fc27.noarch
  dependency: python3-beautifulsoup4
   provider: python3-beautifulsoup4-4.6.0-2.fc27.noarch
  dependency: python3-dbus
   provider: python3-dbus-1.2.4-8.fc27.x86_64
  dependency: python3-lxml
   provider: python3-lxml-3.8.0-1.fc27.x86_64
  dependency: python3-psutil
   provider: python3-psutil-5.2.2-1.fc27.x86_64
  dependency: python3-setuptools
   provider: python3-setuptools-36.2.0-7.fc27.noarch
  dependency: rpm-python3
   provider: python3-rpm-4.14.0-0.rc1.1.fc27.x86_64
  dependency: tracer-common = 0.6.13.1-1.fc27
   provider: tracer-common-0.6.13.1-1.fc27.noarch


And looking into spec, there seems to be a fail in the logic


%if ! %{with suggest}
Suggests:       python2-argcomplete
%else
Requires:       python-argcomplete
%endif


versus


%if %{with suggest}
Suggests:       python3-argcomplete
%else
Requires:       python-argcomplete
%endif


I will fix it.

Comment 3 Jakub Kadlčík 2017-09-28 23:03:20 UTC
PR: https://github.com/FrostyX/tracer/pull/94

Once this is fixed in upstream, I am going to fix the spec in Fedora.

Comment 4 Fedora Update System 2017-10-02 21:51:54 UTC
tracer-0.6.13.1-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bb97b4d465

Comment 5 Fedora Update System 2017-10-02 21:52:10 UTC
tracer-0.6.13.1-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-98104623b5

Comment 6 Fedora Update System 2017-10-02 21:52:20 UTC
tracer-0.6.13.1-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c7bcac8be

Comment 7 Fedora Update System 2017-10-06 03:22:30 UTC
tracer-0.6.13.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-98104623b5

Comment 8 Fedora Update System 2017-10-06 03:24:34 UTC
tracer-0.6.13.1-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bb97b4d465

Comment 9 Fedora Update System 2017-10-06 04:24:56 UTC
tracer-0.6.13.1-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c7bcac8be

Comment 10 Fedora Update System 2018-04-19 21:03:36 UTC
tracer-0.7.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9bf0d24113

Comment 11 Fedora Update System 2018-04-19 21:03:54 UTC
tracer-0.7.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b437cce027

Comment 12 Fedora Update System 2018-04-19 22:37:51 UTC
tracer-0.7.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-e2c57717ce

Comment 13 Fedora Update System 2018-04-21 04:37:44 UTC
tracer-0.7.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b437cce027

Comment 14 Fedora Update System 2018-04-21 05:02:26 UTC
tracer-0.7.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9bf0d24113

Comment 15 Fedora Update System 2018-04-21 06:19:07 UTC
tracer-0.7.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-e2c57717ce

Comment 16 Fedora Update System 2018-04-23 08:38:24 UTC
tracer-0.7.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5d15a730d8

Comment 17 Fedora Update System 2018-04-24 04:46:39 UTC
tracer-0.7.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5d15a730d8

Comment 18 Fedora Update System 2018-04-30 16:36:16 UTC
tracer-0.7.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-04-30 22:02:19 UTC
tracer-0.7.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-05-09 16:13:37 UTC
tracer-0.7.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.