Bug 149210 - /lib/modules/<uname>/build symlink may point to wrong arch
Summary: /lib/modules/<uname>/build symlink may point to wrong arch
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 1352764 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-02-21 07:24 UTC by Ville Skyttä
Modified: 2018-04-11 12:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-28 08:27:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2005-02-21 07:24:58 UTC
As discussed earlier in PM with David:

The current kernel and kernel-devel packages in Rawhide break the earlier
"contract" of /lib/modules/<uname>/build dir/symlink being the correct one for
the corresponding kernel.

Specifically, the correctness of the architecture is not taken care of in any
way.  It is possible to install a kernel-V-R for arch A, and the corresponding
kernel-devel-V-R for arch B, which results in /lib/modules/<uname>/build *not*
pointing to the devel tree for kernel V-R, arch A.

A possible easy fix would be to move the /lib/modules/<uname>/build (and
possibly /lib/modules/<uname>/source) symlink(s) from kernel-devel to the kernel
package(s).  The symlink's target to a /usr/src/kernels/... directory is fine as-is.

Comment 1 David Woodhouse 2005-02-21 17:21:40 UTC
He's right. Dave, can we shift the symlinks into the base kernel package instead
of the -devel package please?

Comment 2 Rik van Riel 2005-03-15 03:19:41 UTC
I'll look into this one, to check if the proposed fix is acceptable.

Comment 3 Rik van Riel 2005-03-15 17:05:32 UTC
The symlinks have just been moved into the base package. The next rawhide kernel
should no longer have this problem.

Comment 4 Ville Skyttä 2005-03-15 18:53:58 UTC
Thanks.  However, looking at the current Rawhide kernel-2.6.spec, I see the
%post scriptlets of xen0-devel and xenU-devel still cd'ing into
/lib/modules/.../build for the hardlinking, which will probably be broken now as
the build symlink is no longer guaranteed to be there.  Shouldn't they be
converted to use /usr/src/kernels/... instead?

By the way, what's the purpose of the pushd/popd "wrapping" in the %post *-devel
scriptlets?  The wrapped block already cd's into the same dir as the pushd...

Comment 5 Rik van Riel 2005-03-15 19:58:02 UTC
I just committed a fix to change the xen0-devel and xenU-devel %post scripts to
hardlink in /usr/src/kernels/...

No idea about the pushd/popd wrapping a cd.  Absolutely no idea...

Comment 6 Rik van Riel 2005-03-16 22:11:45 UTC
OK, the %post scripts have been cleaned up, too.

Comment 7 Warren Togami 2005-05-16 08:30:02 UTC
Everyone satisfied?  close?

Comment 8 Matěj Cepl 2008-07-30 15:57:21 UTC
*** Bug 193477 has been marked as a duplicate of this bug. ***

Comment 9 Josh Boyer 2016-07-05 16:07:41 UTC
*** Bug 1352764 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.