Bug 149220 - RHEL4 U2: Python exception while creating LVM2 volumes
RHEL4 U2: Python exception while creating LVM2 volumes
Status: CLOSED DUPLICATE of bug 168723
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Peter Jones
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-02-21 08:45 EST by Dilpreet Gulati
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-05 11:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda dump (704.42 KB, text/plain)
2005-02-21 08:48 EST, Dilpreet Gulati
no flags Details
Anaconda Dump 2 (777.76 KB, text/plain)
2005-04-21 21:16 EDT, Amit Bhutani
no flags Details

  None (edit)
Description Dilpreet Gulati 2005-02-21 08:45:40 EST
Description of problem:
OS: RHEL4 Gold
Platform: PowerEdge 6650
Installation: GUI/Text
Disks: 2 x (any capacity) disks connected to onboard Adaptec AIC-
7892P U160/m controller
   -Disk 1 has a previous installation of RHEL4 with /boot(ext3) and 
one LVM2 parition (volume group VolGroup00)
   -Disk 2 has a previous installation of RHEL4 with /boot(ext3) and 
one LVM2 partition (volume group VolGroup00) but from a different 

During install, when automatic partitioning is selected and all 
dialogs completed, anaconda throws a python exception (anaconda dump 
file attached) while creating filesystems.

NOTE: This defect is seen ONLY when disks from a previous 
installation of RHEL4 with LVM2 from two DIFFERENT machines are used.

Version-Release number of selected component (if applicable):

How reproducible:
   Every time.

Steps to Reproduce:
   1. Install RHEL4 with autopartioning on 2 machines (machine A and 
machine B) with one disk each. Ensure that there are NO previous LVM 
partitions on both the disks prior to installation
   2. Connect disk from machine A to machine B so that machine B now 
has two disks connected to it
   3. Initiate RHEL4 installation on machine B. Choose 
autopatitioning, complete all dialogs
Actual results:
   1. Python exception is seen just before filesystems are created
   2. Consecutive installs fail with the same exception.

Expected results:
Installation should have deleted the old partitions, created the new 
LVM2 volumes and completed successfully.

Additional info:
   Disk1: /dev/sda 
   Disk2: /dev/sdb
   dd if=/dev/zero of=/dev/sdb count=1 bs=512
and proceeding with the install does not throw the python exception 
and install completes successfully.
Comment 1 Dilpreet Gulati 2005-02-21 08:48:34 EST
Created attachment 111254 [details]
anaconda dump
Comment 2 Matt Domsch 2005-02-21 11:51:03 EST
I believe this to be a duplicate of 144827, which is on our Update 1 

*** This bug has been marked as a duplicate of 144827 ***
Comment 3 Stuart Hayes 2005-04-14 12:37:59 EDT
This bug is still present in RHEL4 Update1 beta 1.
Comment 4 Amit Bhutani 2005-04-19 19:12:33 EDT
I am not convinced that this is a duplicate of BZ144827. 144827 is PROD_READY 
while this one is still reproducible on U1 Beta. I am adding this to Devzilla 
so we can track this.
Comment 5 Amit Bhutani 2005-04-20 16:08:54 EDT
Reopening this issue as it is still reproducible as per Charles Rose 
regression tests.

Paste from BZ144827 as this is pertinent to this bug:
Comment #19 From Charles Rose (charles_rose@dell.com)  on 2005-04-20 05:15 EST 
On RHEL4 U1 Beta we see a Python exception:
I installed two identical PE2850 machines (A and B) with single SCSI disks (No
RAID) with the autopartitioning scheme. Disks on both machines were at SCSI 
The partitions on both the disks (from machine A and machine B) were:
   sda1 (ext3, /boot)
   sda2 (LVM2)
After installation, I moved the disk from machine B and plugged it in machine A
at SCSI ID1 and started the installation (GUI).
I chose to do a fresh Install with autopartition. After the package selection
screen where we usually see the "Formatting" messages, anaconda throws an
exception (file attached) during "lvmremove". Repeated attempts have the same
Comment 6 Amit Bhutani 2005-04-21 21:16:09 EDT
Created attachment 113502 [details]
Anaconda Dump 2
Comment 7 Matt Domsch 2005-04-26 16:26:50 EDT
Here's the culprit text in the dumps:
, fsentry -- device: VolGroup00/LogVol01   mountpoint: swap
           fsystem: swap format: 1
           ismounted: 0
  Unable to deactivate logical volume "LogVol01"

LogVol01 is currently being used as swap space, so lvremove will fail.
Comment 18 Peter Jones 2005-10-05 11:53:36 EDT
I can reproduce this independent of the drives Matt sent in; it's a problem
where you've got two VGs with the same name, and the LVM tools aren't consistent
in their determination of what constitutes "inconsistent metadata", so they'll
let you activate things but not remove or deactivate them.

I realize this is an older bug, but I'm marking it as a dupe of 168723, which is
already assigned to the LVM tools.  And removing it from the proposed list.

(I'm also adding the associated Issue Trackers to that bug)

*** This bug has been marked as a duplicate of 168723 ***

Note You need to log in before you can comment on or make changes to this bug.