Bug 1492210 - isl FTBFS in rawhide
Summary: isl FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: isl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Howells
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-15 19:26 UTC by Troy Dawson
Modified: 2017-09-25 14:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-25 14:21:17 UTC
Type: Bug


Attachments (Terms of Use)
isl spec patch to fix setup problem (853 bytes, patch)
2017-09-15 19:33 UTC, Troy Dawson
no flags Details | Diff

Description Troy Dawson 2017-09-15 19:26:55 UTC
Description of problem:
Due to a change in the rpm %setup macro, isl no longer builds in rawhide.  I believe the only reason isl was building before the rpm change was due to a bug in the %setup macro.

Version-Release number of selected component (if applicable):
isl-0.16.1-3.fc27

How reproducible:
100%

Steps to Reproduce:
1.koji build --scratch rawhide isl-0.16.1-3.fc27.src.rpm
2.
3.

Actual results:
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.Esu1Py
+ umask 022
+ cd /builddir/build/BUILD
+ cd isl
+ cd isl-0.14
/var/tmp/rpm-tmp.Esu1Py: line 31: cd: isl-0.14: No such file or directory


Expected results:
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.12Czdl
+ umask 022
+ cd /home/quake/rpmbuild/BUILD
+ cd isl
+ cd isl-0.14
+ CFLAGS='-O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic'
...
and a successful build

Additional info:

Comment 1 Troy Dawson 2017-09-15 19:33:30 UTC
Created attachment 1326598 [details]
isl spec patch to fix setup problem

If you use -a (Unpack The nth Sources After Changing Directory) instead of -b (Unpack The nth Sources Before Changing Directory) then you will get what you want.
The only reason it was working before was because you we doing setup twice and there was a minor bug in the setup macro.
I also commented out the first setup instance because when you use -b or -a, it also unpackges the normal source, unless you tell it not to with -T

Comment 2 Troy Dawson 2017-09-15 19:36:46 UTC
This is a bit of a blocker bug for modularity.  We are trying to create tools that rebuild everything, and this package is failling.

We understand that time is important, and not everyone is able to fix bugs quickly.  If this bug isn't updated in two weeks, we will have a proven packager apply this patch.  If you know you will not be able to fix this build, and would like us to fix it sooner, please let us know.

Comment 3 Troy Dawson 2017-09-25 14:21:17 UTC
Fixed in isl-0.16.1-4.fc28


Note You need to log in before you can comment on or make changes to this bug.