Bug 1492226 - RFE: Ability to attach iso to existing VM
Summary: RFE: Ability to attach iso to existing VM
Keywords:
Status: CLOSED DUPLICATE of bug 1449607
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Eoghan Glynn
QA Contact: Joe H. Rahme
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-15 20:41 UTC by Jeremy
Modified: 2020-12-14 10:05 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-15 21:35:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jeremy 2017-09-15 20:41:13 UTC
Description of problem: Customers have the need to attach ISO to an instance that is already running. Currently there seems to only be possible to attach volume as type cdrom at boot time: https://access.redhat.com/solutions/1225473

Having this feature would allow customers to attach volumes containing iso image as type cdrom so they can install apps on windows vm and such via the iso.

Comment 1 Lee Yarwood 2017-09-15 21:35:01 UTC
So stable device rescue is what we really need here, the current behaviour of using the disk_bus of the original image or default in nova.conf is enough in the general volume-attach use-case.

*** This bug has been marked as a duplicate of bug 1449607 ***


Note You need to log in before you can comment on or make changes to this bug.