This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 149225 - Macaulay2 x86_64 build fix
Macaulay2 x86_64 build fix
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Macaulay2 (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 10:21 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 04:18:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x86_64 specfile patch (4.30 KB, patch)
2005-02-21 10:21 EST, Rex Dieter
no flags Details | Diff
x86_64 specfile patch (take 2) (4.30 KB, patch)
2005-02-21 10:36 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2005-02-21 10:21:36 EST
Here's a specfile fix to the build issue documented at
http://www.leemhuis.info/files/fedorarpms/misc/Macaulay2.x86_64.log

 %changelog
* Mon Feb 21 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0:0.9.2-14
- x86_64 issues (%%_libdir -> %%_prefix/lib )
- remove desktop_file macro usage
Comment 1 Rex Dieter 2005-02-21 10:21:36 EST
Created attachment 111258 [details]
x86_64 specfile patch
Comment 2 Rex Dieter 2005-02-21 10:36:10 EST
Created attachment 111259 [details]
x86_64 specfile patch (take 2)

patch that actually works this time (previous had an extraneous %endif)
Comment 3 Thorsten Leemhuis 2005-03-24 15:05:59 EST
Rex, there is a typo in you patch in the files section (search for "m2hoome")

Im also unsure if I like this solution. Especially if we can tolerate this file
in /usr/lib/:

/usr/lib/Macaulay2-0.9.2/libexec/Macaulay2: ELF 64-bit LSB executable, AMD
x86-64, version 1 (SYSV), for GNU/Linux 2.4.0, dynamically linked (uses shared
libs), stripped

Michael, what do you think?
Comment 4 Michael Schwendt 2005-03-24 22:22:24 EST
If Macaulay2 builds for x86_64 and we don't ship an i386 Macaulay2 in the x86_64
Extras repo, there's no need to relocate it further. This package does not
provide any 64-bit or 32-bit libraries shared with other 64-bit or 32-bit
applications. Since this is an application package and not a library provider,
it cannot coexist (as in "parallel installable") with an i386 Macaulay2 anyway.
Other x86_64 packages put executables into their home directories below
/usr/lib/foo, too, btw. E.g. xcdroast.

As a side-note, if one really wanted to, it shouldn't be a problem to move
/usr/lib/Macaulay2-0.9.2/libexec to /usr/lib64/Macaulay2-0.9.2/libexec and
adjust /usr/bin/M2 accordingly. Is there any other place where the libexec
directory is hardcoded?
Comment 5 Thorsten Leemhuis 2005-03-25 08:50:37 EST
(In reply to comment #4)
> If Macaulay2 builds for x86_64 and we don't ship an i386 Macaulay2 in the x86_64
> Extras repo, there's no need to relocate it further.

Thanks for the clarification -- I was unsure on that. 

Rex, shall I commit the patch to cvs and request a build? Afaik your paperwork
for cvs is still in the works?
Comment 6 Rex Dieter 2005-03-25 08:54:02 EST
Yes, yes, respectively (don't know what the cvs holdup is... the last contact I
had was March 5th...)
Comment 7 Thorsten Leemhuis 2005-03-25 10:20:34 EST
Commited. Will request build tomorrow.
Comment 8 Thorsten Leemhuis 2005-05-10 03:56:17 EDT
Build was done and succeed yesterday after problems with the buildsystem before.
Please close (I can't)

Note You need to log in before you can comment on or make changes to this bug.