Bug 1492306 - English (Australia) marks "etc etc." as misspelled
Summary: English (Australia) marks "etc etc." as misspelled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell-en
Version: 26
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-16 09:36 UTC by Luigi Cantoni
Modified: 2017-09-30 06:55 UTC (History)
11 users (show)

Fixed In Version: hunspell-en-0.20140811.1-9.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-30 06:55:21 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1495084 0 unspecified CLOSED hunspell-en-0.20140811.1-8.fc28 does not recognize valid words (from, the, process) 2021-02-22 00:41:40 UTC

Internal Links: 1495084

Description Luigi Cantoni 2017-09-16 09:36:17 UTC
Description of problem:
etc. spelling correction has issues.

Version-Release number of selected component (if applicable):
hunspell.x86_64                      1.5.4-2.fc26
hunspell.x86_64                      1.5.4-2.fc26  

How reproducible:
Totally

Steps to Reproduce:
1. create a new email
2. Type this sentence etc. Then this.
Type this sentence etc. Then this.
Type this sentence etc. Then this.
3. It needs to have the etc. repeated.
4. Then do a spelling checker.
5. pick the etc. entry and say replace all.
6. It repeat corrects itself.

Actual results:
etc........
until you close the window and stop it.

Expected results:
Should not even consider etc. a spelling error

Additional info:
Libreoffice does it correctly as it does not consider etc. an error in the document and if you lean the "." off it corrects it just once and all is good.

Comment 1 Milan Crha 2017-09-18 06:45:54 UTC
Thanks for a bug report. I see you report two issues, one is about "Replace All" function in Spell checking, another is about "incorrect word boundary detection".

The word boundary detection is fully dependant on WebKitGTK+ and from what I test here, with (rpm -qa evolution webkitgtk4 hunspell* | sort):
   evolution-3.24.5-1.fc26.x86_64
   hunspell-1.5.4-2.fc26.x86_64
   hunspell-cs-20080822-6.fc26.noarch
   hunspell-de-0.20160407-2.fc26.noarch
   hunspell-devel-1.5.4-2.fc26.x86_64
   hunspell-en-0.20140811.1-6.fc26.noarch
   hunspell-en-GB-0.20140811.1-6.fc26.noarch
   hunspell-en-US-0.20140811.1-6.fc26.noarch
   hunspell-sv-2.28-6.fc26.noarch
   webkitgtk4-2.16.6-1.fc26.x86_64
the "etc." is not shown as misspelled, while I have only Edit->Current Languages->English (United States) checked in the menu of the message composer.

As I cannot reproduce the first part, I'm not able to confirm the second part.

Comment 2 Luigi Cantoni 2017-09-18 07:32:55 UTC
Good point about the dictionary. I am using English (Australia) and I really should have said that.
You are 100% correct that with English (US) etc. is not a spelling error at all and thus the issue does not arise.
English (UK) also considers it a spelling error (English Australia, is more like English UK than English US).
You are correct in that the auto correct problem is "different" but I think there is no case where it would fail if the spelling checker correctly did the etc. case. This it will probably not exist once the dictionary is corrected.

NOTE: I thought libreoffice was using the same dictionary/spelling checking arrangement as evolution (both using hunspell etc) but I am not 100% sure now.

Comment 3 Milan Crha 2017-09-18 14:24:23 UTC
Okay, I tested this with gtkhtml-editor-test (which comes from gtkhtml3-devel package) and it also underlines "etc etc." when used with "English (Australia)" dictionary. My Firefox has set "English (Australia)" too now (I just changed it in the context menu of this text area), and it also doesn't like the "etc etc." from two lines above.

Thus I'd say this is about the hunspell dictionary, rather than respective application.

I changed the bug summary naming "English (Australia)" there, but please note that other English variants can work similarly.

Comment 4 Caolan McNamara 2017-09-21 10:38:58 UTC
might as well set etc the same in GB (and linked subvariants) and US I suppose, though the dict isn't wrong per-se, just . is a miserable duplicate symbol for abbreviation and end of sentence

Comment 5 Fedora Update System 2017-09-21 11:19:31 UTC
hunspell-en-0.20140811.1-8.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f9ec2608c3

Comment 6 Fedora Update System 2017-09-21 23:59:16 UTC
hunspell-en-0.20140811.1-8.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f9ec2608c3

Comment 7 Fedora Update System 2017-09-25 11:31:26 UTC
hunspell-en-0.20140811.1-9.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d4a388a428

Comment 8 Fedora Update System 2017-09-25 16:23:47 UTC
hunspell-en-0.20140811.1-9.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d4a388a428

Comment 9 Fedora Update System 2017-09-30 06:55:21 UTC
hunspell-en-0.20140811.1-9.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.