Bug 1492389 - dnf repoquery --unsatisfied produces bogus results
Summary: dnf repoquery --unsatisfied produces bogus results
Keywords:
Status: CLOSED DUPLICATE of bug 1473262
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-17 05:59 UTC by Ralf Corsepius
Modified: 2017-09-20 11:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-20 11:24:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Ralf Corsepius 2017-09-17 05:59:37 UTC
Description of problem:

# rpm -qa 'kernel*' |sort
kernel-4.12.11-300.fc26.x86_64
kernel-4.12.12-300.fc26.x86_64
kernel-4.12.9-300.fc26.x86_64
kernel-core-4.12.11-300.fc26.x86_64
kernel-core-4.12.12-300.fc26.x86_64
kernel-core-4.12.9-300.fc26.x86_64
kernel-headers-4.12.12-300.fc26.x86_64
kernel-modules-4.12.11-300.fc26.x86_64
kernel-modules-4.12.12-300.fc26.x86_64
kernel-modules-4.12.9-300.fc26.x86_64
kernel-tools-libs-4.12.12-300.fc26.x86_64


# dnf repoquery --duplicates
Last metadata expiration check: 0:21:57 ago on Sun 17 Sep 2017 07:36:25 AM CEST.

# dnf repoquery --unsatisfied
Last metadata expiration check: 0:19:37 ago on Sun 17 Sep 2017 07:36:25 AM CEST.
The operation would result in removing the following protected packages: kernel-core

What the **** is going on here?

Version-Release number of selected component (if applicable):
dnf-plugins-core-2.1.3-1.fc26.noarch
dnf-conf-2.6.3-11.fc26.noarch
dnf-2.6.3-11.fc26.noarch

Comment 1 Igor Gnatenko 2017-09-20 11:24:12 UTC

*** This bug has been marked as a duplicate of bug 1473262 ***


Note You need to log in before you can comment on or make changes to this bug.