Bug 1492456 - Instead of an error message, I get a success message when I upload a bad file as a plan
Summary: Instead of an error message, I get a success message when I upload a bad file...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Ana Krivokapic
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-17 13:17 UTC by Udi
Modified: 2018-06-27 13:37 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-ui-8.2.1-0.20180227100337.517cd78.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 508145 None master: MERGED tripleo-ui: Validate extension for tarballs on plan create/update (I38400546f860adc33a3de33176c8a557d2180810) 2018-02-28 13:35:52 UTC
OpenStack gerrit 512302 None stable/pike: MERGED tripleo-ui: Validate extension for tarballs on plan create/update (I38400546f860adc33a3de33176c8a557d2180810) 2018-02-28 13:35:44 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:03 UTC

Description Udi 2017-09-17 13:17:17 UTC
Description of problem:
In the Plans page, I selected a plan and clicked "Edit", and I uploaded a png image instead of a .tar.gz archive. I got a success message "The plan plan1 was successfully updated", although it really wasn't updated and I should have gotten an error message.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.2.1-0.20170819031831.070a522.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Navigate to the Plans page
2. For one of the plans, click on the kebab menu and click "Edit"
3. Upload a new file instead of the .tar.gz file (I used a png file in my example)
4. Click "Upload Files and Create Plan"


Actual results:
You get a success message, although the plan wasn't updated at all.


Expected results:
Error message.

Comment 5 Udi 2018-04-15 09:43:47 UTC
Verified in: openstack-tripleo-ui-8.3.1-2.el7ost.noarch

Comment 7 errata-xmlrpc 2018-06-27 13:36:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.