Bug 1492465 - Nodes action buttons shouldn't be clickable and do any action if no nodes are registered
Summary: Nodes action buttons shouldn't be clickable and do any action if no nodes are...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-17 13:58 UTC by Ola Pavlenko
Modified: 2018-06-27 13:37 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-ui-8.1.1-0.20180122135122.aef02d8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1703818 None None None 2017-10-05 10:50:35 UTC
OpenStack gerrit 508910 None master: MERGED tripleo-ui: Make the Nodes dropdown actions truly disabled (Ie11664dbf275682fda613f96cb5418e3b86dd3d9) 2018-02-07 14:35:32 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:03 UTC

Description Ola Pavlenko 2017-09-17 13:58:45 UTC
Description of problem:
When no nodes are registered in UI, all buttons in nodes tab are "disabled"
Despite this, "tag nodes " and other options are clickable and actionable
Clicking on "Tag nodes" for example pops up "Tag Nodes into Profiles" window 

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.3.1-0.20170830131652.f61181a.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. delete default plan so there are no plans in UI
2. delete all nodes
3. on Nodes tab choose "tag nodes" 

Actual results:
"Tag Nodes into Profiles" window  pops up 
closing the pop up window turns all buttons to "available"

Expected results:
Button is disabled and not actionable

Additional info:

Comment 3 Jiri Tomasek 2017-10-02 15:22:48 UTC
Fixed by https://review.openstack.org/508910

Comment 7 Jason E. Rist 2018-04-05 21:57:42 UTC
definitely fixed in openstack-tripleo-ui-8.3.1-2.el7ost.noarch

Comment 9 errata-xmlrpc 2018-06-27 13:36:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.